Bug 1731108 - [virtual block] Cannot format data disk after "system_reset while running iozone" on win7 and win2008R2
Summary: [virtual block] Cannot format data disk after "system_reset while running ioz...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux Advanced Virtualization
Classification: Red Hat
Component: qemu-kvm
Version: ---
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Vadim Rozenfeld
QA Contact: CongLi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-18 10:10 UTC by Yu Wang
Modified: 2019-10-24 01:14 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-24 01:14:53 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)
disk_format_error (65.84 KB, image/png)
2019-07-18 10:15 UTC, Yu Wang
no flags Details
event_viewer_log (177.08 KB, application/zip)
2019-10-10 10:08 UTC, Yu Wang
no flags Details

Description Yu Wang 2019-07-18 10:10:19 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:

1. boot guest with data disk

MALLOC_PERTURB_=1  /usr/libexec/qemu-kvm \
     -S  \
     -name 'avocado-vt-vm1' \
     -machine pc  \
     -nodefaults \
     -device VGA,bus=pci.0,addr=0x2  \
     -chardev socket,id=qmp_id_qmpmonitor1,path=/var/tmp/avocado_hdlskmio1,server,nowait \
     -mon chardev=qmp_id_qmpmonitor1,mode=control  \
     -chardev socket,id=qmp_id_catch_monitor,path=/var/tmp/avocado_hdlskmio1,server,nowait \
     -mon chardev=qmp_id_catch_monitor,mode=control \
     -device pvpanic,ioport=0x505,id=idTP0mxi \
     -chardev socket,server,path=/var/tmp/avocado_hdlskmio1,nowait,id=chardev_serial0 \
     -device isa-serial,id=serial0,chardev=chardev_serial0  \
     -chardev socket,id=seabioslog_id_20190718-010149-M75DaHRZ,path=/var/tmp/avocado_hdlskmio1,server,nowait \
     -device isa-debugcon,chardev=seabioslog_id_20190718-010149-M75DaHRZ,iobase=0x402 \
     -device qemu-xhci,id=usb1,bus=pci.0,addr=0x3 \
     -drive id=drive_image1,if=none,snapshot=off,aio=threads,cache=none,format=qcow2,file=/home/kvm_autotest_root/images/win7-32-sp1-virtio.qcow2 \
     -device virtio-blk-pci,id=image1,drive=drive_image1,bootindex=0,bus=pci.0,addr=0x4 \
     -drive id=drive_stg,if=none,snapshot=off,aio=threads,cache=none,format=qcow2,file=/home/kvm_autotest_root/images/storage.qcow2 \
     -device virtio-blk-pci,id=stg,drive=drive_stg,bootindex=1,serial=TARGET_DISK0,bus=pci.0,addr=0x5 \
     -device virtio-net-pci,mac=9a:e2:48:57:e2:0d,id=id9VcN6M,netdev=idqKq1FS,bus=pci.0,addr=0x6  \
     -netdev tap,id=idqKq1FS,vhost=on \
     -m 4096  \
     -smp 4,maxcpus=4,cores=2,threads=1,sockets=2  \
     -cpu 'EPYC',hv_stimer,hv_synic,hv_vpindex,hv_reset,hv_relaxed,hv_spinlocks=0x1fff,hv_vapic,hv_time,hv-tlbflush,+kvm_pv_unhalt \
     -drive id=drive_cd1,if=none,snapshot=off,aio=threads,cache=none,media=cdrom,file=/home/kvm_autotest_root/iso/windows/winutils.iso \
     -device ide-cd,id=cd1,drive=drive_cd1,bootindex=2,bus=ide.0,unit=0 \
     -device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1  \
     -vnc :0  \
     -rtc base=localtime,clock=host,driftfix=slew  \
     -boot order=cdn,once=c,menu=off,strict=off \
     -enable-kvm \
     -monitor stdio


2. format data disk

3. D:\Iozone\iozone.exe -azR -r 64k -n 1G -g 10G -M -i 0 -i 1 -I -f E:\testfile

4. (qemu)system_reset

5. check device manager and format datadisk

Actual results:
cannot format this disk and occurred error


Expected results:
format successfully

Additional info:
1 hit this issue with ide data disk too.
2 hit this issue on win7-32/64 and win2008R2, cannot hit on win8-32 and win2019
3 cannot hit this issue with "shutdown -t 0 -s/-r" in guest

Comment 1 Yu Wang 2019-07-18 10:15:01 UTC
Created attachment 1591739 [details]
disk_format_error

Comment 2 Yu Wang 2019-07-18 10:19:41 UTC
Note:

1 Need to run on a clean image
2 we can format this data disk successfully by change to GPT. Then this guest can be formatted with MBR, too.

Thanks
Yu Wang

Comment 4 Yu Wang 2019-07-19 03:25:51 UTC
version:
kernel-4.18.0-107.el8.x86_64
qemu-kvm-4.0.0-5.module+el8.1.0+3622+5812d9bf.x86_64
seabios-bin-1.12.0-3.module+el8.1.0+3627+66216cf4.noarch
virtio-win-prewhql-172/171/158

Thanks
Yu Wang

Comment 5 Ademar Reis 2019-07-26 21:47:28 UTC
We need someone who's familiar with the windows side to better diagnose this problem.

Comment 7 Vadim Rozenfeld 2019-08-19 03:10:17 UTC
(In reply to Yu Wang from comment #1)
> Created attachment 1591739 [details]
> disk_format_error

Hi Yu Wang,
Can you please export and upload the System Event Log file?

Thanks,
Vadim.

Comment 8 Yu Wang 2019-10-10 10:06:59 UTC
Hi Vadim

(In reply to Vadim Rozenfeld from comment #7)
> (In reply to Yu Wang from comment #1)
> > Created attachment 1591739 [details]
> > disk_format_error
> 
> Hi Yu Wang,
> Can you please export and upload the System Event Log file?

I reproduce this bug with qemu-kvm-4.1.0-5.module+el8.1.0+4076+b5e41ebc.x86_64
Log refer to the attachment

But I cannot reproduce this issue with the latest qemu(qemu-kvm-4.1.0-13.module+el8.1.0+4313+ef76ec61.x86_64)

Thanks
Yu Wang

> 
> Thanks,
> Vadim.

Comment 9 Yu Wang 2019-10-10 10:08:36 UTC
Created attachment 1624250 [details]
event_viewer_log

Comment 10 Vadim Rozenfeld 2019-10-13 09:22:16 UTC
(In reply to Yu Wang from comment #9)
> Created attachment 1624250 [details]
> event_viewer_log

Thanks a lot.
I found only one critical level event in the system log, saying 
that system rebooted without clean shutdown.
Unfortunatly no bugcheck was reported at this time.
So. lets keep watching this problem. Hopefuly we will have
more information in the future to troubleshoot this issue.

Best,
Vadim.

Comment 11 Yu Wang 2019-10-23 08:14:48 UTC
Hi Vadim,

(In reply to Vadim Rozenfeld from comment #10)
> (In reply to Yu Wang from comment #9)
> > Created attachment 1624250 [details]
> > event_viewer_log
> 
> Thanks a lot.
> I found only one critical level event in the system log, saying 
> that system rebooted without clean shutdown.
> Unfortunatly no bugcheck was reported at this time.
> So. lets keep watching this problem. Hopefuly we will have
> more information in the future to troubleshoot this issue.
> 
As I said in comment#7
I cannot reproduce this issue with the latest qemu(qemu-kvm-4.1.0-13.module+el8.1.0+4313+ef76ec61.x86_64)
I can reproduce this bug with qemu-kvm-4.1.0-5.module+el8.1.0+4076+b5e41ebc.x86_64 (the bug reported version)

so maybe this bug can be closed as current release.

Thanks
Yu Wang

> Best,
> Vadim.

Comment 12 Vadim Rozenfeld 2019-10-24 01:14:53 UTC
(In reply to Yu Wang from comment #11)
> Hi Vadim,
> 
> (In reply to Vadim Rozenfeld from comment #10)
> > (In reply to Yu Wang from comment #9)
> > > Created attachment 1624250 [details]
> > > event_viewer_log
> > 
> > Thanks a lot.
> > I found only one critical level event in the system log, saying 
> > that system rebooted without clean shutdown.
> > Unfortunatly no bugcheck was reported at this time.
> > So. lets keep watching this problem. Hopefuly we will have
> > more information in the future to troubleshoot this issue.
> > 
> As I said in comment#7
> I cannot reproduce this issue with the latest
> qemu(qemu-kvm-4.1.0-13.module+el8.1.0+4313+ef76ec61.x86_64)
> I can reproduce this bug with
> qemu-kvm-4.1.0-5.module+el8.1.0+4076+b5e41ebc.x86_64 (the bug reported
> version)
> 
> so maybe this bug can be closed as current release.
> 
> Thanks
> Yu Wang
> 
> > Best,
> > Vadim.

Thanks a lot Yu Wang,
Let's close it then,
All the best,
Vadim.


Note You need to log in before you can comment on or make changes to this bug.