Bug 1731134 - HCL for rhcos missing
Summary: HCL for rhcos missing
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: RHCOS
Version: 4.1.0
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
: ---
Assignee: Steve Milner
QA Contact: Micah Abbott
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-18 11:58 UTC by Jure Pečar
Modified: 2019-11-08 22:25 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-08 22:25:53 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jure Pečar 2019-07-18 11:58:41 UTC
Description of problem:

I'm exploring the bare metal openshift options, so far with no luck. Deploying openshift requires some nodes to be installed with CoreOS. On one type of hardware I have (IBM HS23 blades) network card is not recognized (Emulex, be2net driver) and installation cannot pull the image. On another type of hardware I have (Dell R410) raid controller is not recognized and no disks are available for installation to proceed.

Version-Release number of selected component (if applicable):
4.1.0

How reproducible:
With this hardware, always.

Steps to Reproduce:
1. Find random old hardware
2. Try deploying CoreOS on it
3.

Actual results:
Installation fails.

Expected results:
Installation should succeed.

Additional info:
There is no HCL provided for CoreOS as is for RHEL so I cannot tell in advance what hardware do I need for baremetal openshift deployment to work.

Comment 1 Colin Walters 2019-07-18 12:42:29 UTC
RHEL CoreOS *is* RHEL.  This type of thing is exactly why the name includes RHEL. There is no separate HCL.

If those devices aren't on the RHEL HCL, they aren't supported.  I know several old hardware RAID controllers were indeed dropped from RHEL 8 (which RHCOS currently tracks).

Comment 2 Jure Pečar 2019-07-18 13:09:29 UTC
Ok, so you're saying that RHEL8 HCL applies to RHCOS 4.1? Valid answer, but I would like to see it mentioned somewhere in the documentation.

With that, I can happily recommend that we trash most of our old hardware, since it's not usable even for the lab ;)

Comment 3 Colin Walters 2019-07-18 13:18:16 UTC
Yes...this does need to be documented.  And I think it's another argument for having the underlying OS version clearly exposed too.

Comment 4 Steve Milner 2019-07-18 13:28:39 UTC
Adding Ben Breard to the discussion.

Comment 7 Masaki Furuta 2019-10-09 06:53:46 UTC
(In reply to Masaki Furuta from comment #6)
Hi Steve Milner,

Please find my question at comment 6 ( I kept it private because it has RH internal only URL ).
And Would you please give me any news on this bz ?

I am grateful for your help and clarification.

Thank you,

BR,
Masaki

Comment 9 Micah Abbott 2019-11-08 22:25:53 UTC
Customers should reference the RHEL 8 HCL when evaluating infrastructure to run OCP/RHCOS.


Note You need to log in before you can comment on or make changes to this bug.