Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1731147 - gluster_infra_mount_devices listed twice in gluster_inventory.yml
Summary: gluster_infra_mount_devices listed twice in gluster_inventory.yml
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: gluster-ansible
Version: rhgs-3.5
Hardware: All
OS: All
unspecified
urgent
Target Milestone: ---
: RHGS 3.5.z Batch Update 2
Assignee: Gobinda Das
QA Contact: SATHEESARAN
URL:
Whiteboard:
Depends On:
Blocks: 1810044
TreeView+ depends on / blocked
 
Reported: 2019-07-18 13:03 UTC by Kim Borup
Modified: 2020-06-16 05:57 UTC (History)
7 users (show)

Fixed In Version: gluster-ansible-roles-1.0.5-7.el8rhgs
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1810044 (view as bug list)
Environment:
rhhiv, rhel8
Last Closed: 2020-06-16 05:57:29 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2020:2575 0 None None None 2020-06-16 05:57:52 UTC

Description Kim Borup 2019-07-18 13:03:40 UTC
Description of problem:
In the file gluster_inventory.yml the variable gluster_infra_mount_devices are listed twice for each host, as a variable can only be there once it will give out warnings and errors. 

Version-Release number of selected component (if applicable):
1.6 1.7

How reproducible:
Every install

Steps to Reproduce:
1. Install newest RHHI Hypervisor iso. 
2. Check gluster_inventory.yml
3.

Actual results:
gluster_infra_mount_devices listed twice per host. 

Expected results:
listed once per host. 

Additional info:
Also missing from documentation as a thing you have to edit.

Comment 3 Sachidananda Urs 2019-07-30 05:00:04 UTC
Fixed by @kborup via PR: https://github.com/gluster/gluster-ansible/pull/78

Comment 6 Gobinda Das 2020-02-19 06:45:51 UTC
Trageted for 3.5.2

Comment 12 SATHEESARAN 2020-03-20 13:12:06 UTC
Tested with gluster-ansible-roles-1.0.5-7.el8rhgs

Redundant entries 'gluster_infra_mount_devices' per host section is now removed

[root@ ~]# grep gluster_infra_mount_devices /etc/ansible/roles/gluster.ansible/playbooks/hc-ansible-deployment/gluster_inventory.yml 
      gluster_infra_mount_devices:
      gluster_infra_mount_devices:
      gluster_infra_mount_devices:

Comment 16 errata-xmlrpc 2020-06-16 05:57:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2020:2575


Note You need to log in before you can comment on or make changes to this bug.