Bug 173116 - crash when rfc2047_encode_word" called with "type=NULL"
crash when rfc2047_encode_word" called with "type=NULL"
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: evolution (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
: Desktop
Depends On:
Blocks: 181409
  Show dependency treegraph
 
Reported: 2005-11-14 06:33 EST by David Juran
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2006-0491
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-10 17:19:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
replying to this email will make evolution crash (2.91 KB, text/plain)
2005-11-14 06:35 EST, David Juran
no flags Details
backtrace from evolution (6.98 KB, text/plain)
2005-11-14 06:37 EST, David Juran
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 300679 None None None Never
GNOME Desktop 315547 None None None Never

  None (edit)
Description David Juran 2005-11-14 06:33:17 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.7.12) Gecko/20050921 Red Hat/1.0.7-1.4.1 Firefox/1.0.7

Description of problem:
When trying to reply to a specific message, evolution will crash. This is identical to the bugs http://bugzilla.gnome.org/show_bug.cgi?id=315547 and http://bugzilla.gnome.org/show_bug.cgi?id=300679 and I can verify that they are fixed in evolution-2.4.1-7 in rawhide.
However I do believe this fix should be back ported to RHEL4, since AFAIK, there is no workaround for it and it prevents a user from replying to specific emails.

I'm also attaching a back trace

Version-Release number of selected component (if applicable):
evolution-2.0.2-22

How reproducible:
Always

Steps to Reproduce:
1. Reply to the attached email by typing a few lines at random
2. watch evolution crash
3.
  

Additional info:
Comment 1 David Juran 2005-11-14 06:35:15 EST
Created attachment 121017 [details]
replying to this email will make evolution crash
Comment 2 David Juran 2005-11-14 06:37:14 EST
Created attachment 121018 [details]
backtrace from evolution
Comment 3 David Juran 2005-11-14 06:46:21 EST
Oh, and the work around is of course to delete the offending character from the
subject line the first thing you do when replying to the email...
Comment 9 Red Hat Bugzilla 2006-08-10 17:19:48 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0491.html

Note You need to log in before you can comment on or make changes to this bug.