Bug 1731185 - DB restore from nfs doesn't give feedback on erro and just hangs.
Summary: DB restore from nfs doesn't give feedback on erro and just hangs.
Keywords:
Status: CLOSED DUPLICATE of bug 1662991
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance
Version: 5.10.7
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: GA
: 5.11.0
Assignee: Gregg Tanzillo
QA Contact: Jaroslav Henner
Red Hat CloudForms Documentation
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-18 14:37 UTC by Jaroslav Henner
Modified: 2019-07-22 14:03 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-22 11:12:27 UTC
Category: Bug
Cloudforms Team: CFME Core
Target Upstream Version:


Attachments (Terms of Use)

Description Jaroslav Henner 2019-07-18 14:37:11 UTC
Description of problem:
When restoring from NFS using the appliance console option 6 and the evmserverd is running, I can see the error in evm.log:


----] I, [2019-07-18T10:30:19.327877 #29323:11b8f54]  INFO -- : MIQ(MiqNfsSession-mount_share) Connecting to host: [10.8.198.142], share: [/srv/export/db_backup/tmp] using mount point: [/tmp/miq_20190718-29323-v3bw4v]...
[----] I, [2019-07-18T10:30:19.372294 #29323:11b8f54]  INFO -- : MIQ(MiqNfsSession-mount_share) Connecting to host: [10.8.198.142], share: [/srv/export/db_backup/tmp]...Complete
[----] I, [2019-07-18T10:30:19.372461 #29323:11b8f54]  INFO -- : MIQ(MiqNfsSession-relative_to_mount) mount point [/srv/export/db_backup/tmp], uri: [nfs://10.8.198.142/srv/export/db_backup/tmp/evm_db.backup]...
[----] I, [2019-07-18T10:30:19.372602 #29323:11b8f54]  INFO -- : MIQ(MiqNfsSession-relative_to_mount) mount point [/srv/export/db_backup/tmp], uri: [nfs://10.8.198.142/srv/export/db_backup/tmp/evm_db.backup]...relative: [evm_db.backup]
[----] I, [2019-07-18T10:30:19.373346 #29323:11b8f54]  INFO -- : MIQ(MiqNfsSession-download) Copying file [/tmp/miq_20190718-29323-v3bw4v/evm_db.backup] to [#<File:0x000000000235bb80>]...
[----] E, [2019-07-18T10:30:19.417997 #29323:11addac] ERROR -- : MIQ(EvmDatabaseOps.prepare_for_restore) Database restore failed. Shut down all evmserverd processes before attempting a database restore

I can see no indication that something had failed in the appliance console:

Restore Database From Backup


Note: A database restore cannot be undone.  The restore will use the file: nfs://10.8.198.142/srv/export/db_backup/tmp/evm_db.backup.
Are you sure you would like to restore the database? (Y/N): y

Restoring the database...
*** Hangs forever here***


I also would expect the log lines about restore in the appliance_console log rather in the evm.log


Version-Release number of selected component (if applicable):
5.10.7.1

How reproducible:
2/2

Steps to Reproduce:
1. Backup the db to nfs using option 4
2. Try restoring the db from nfs using option 6 without shutting down the evmserverd.
3.

Actual results:
No progress informatin about the restore. No error.

Expected results:
 * restore operation either shuts down evmserverd and then restores or
 * error message about that user needs to shut the evmserverd down appears in the apliance_console stderror/stdoutput

Some progress information would be great to have.




Additional info:

Comment 2 Yuri Rudman 2019-07-18 15:15:49 UTC
it looks like this BZ is duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1662991

Comment 3 Yuri Rudman 2019-07-22 11:12:27 UTC

*** This bug has been marked as a duplicate of bug 1662991 ***


Note You need to log in before you can comment on or make changes to this bug.