Bug 1731188 - [3.10] master-controllers log spammed with "The resourceVersion for the provided watch is too old." warning messages
Summary: [3.10] master-controllers log spammed with "The resourceVersion for the provi...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: kube-controller-manager
Version: 3.9.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.10.z
Assignee: Jack Ottofaro
QA Contact: zhou ying
URL:
Whiteboard:
Depends On: 1731187
Blocks: 1573460
TreeView+ depends on / blocked
 
Reported: 2019-07-18 14:42 UTC by Eric Rich
Modified: 2019-09-10 23:59 UTC (History)
24 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Warning message reported by etcd roughly every 7 seconds Consequence: Excessive logging. Fix: Changed log level to info.
Clone Of: 1573460
Environment:
Last Closed: 2019-09-10 23:59:06 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2688 None None None 2019-09-10 23:59:10 UTC

Comment 1 Jack Ottofaro 2019-07-18 20:03:32 UTC
PR created https://github.com/openshift/origin/pull/23425

Comment 3 zhou ying 2019-09-04 08:46:45 UTC
Confirmed with latest version: 
[root@preserve-xjiang37dmaster-etcd-nfs-1 ~]#  oc version
oc v3.10.169
kubernetes v1.10.0+b81c8f8
features: Basic-Auth GSSAPI Kerberos SPNEGO

Server https://preserve-xjiang37dmaster-etcd-nfs-1:8443
openshift v3.10.169
kubernetes v1.10.0+b81c8f8


The issue has fixed:
[root@preserve-xjiang37dmaster-etcd-nfs-1 ~]# oc logs -f po/master-controllers-preserve-xjiang37dmaster-etcd-nfs-1 -n kube-system |grep  -i "The resourceVersion for the provided watch is too old"
I0904 02:58:22.485528       1 reflector.go:343] github.com/openshift/origin/vendor/github.com/openshift/client-go/template/informers/externalversions/factory.go:58: watch of *v1.TemplateInstance ended with: The resourceVersion for the provided watch is too old.
I0904 02:59:14.572259       1 reflector.go:343] github.com/openshift/origin/vendor/k8s.io/client-go/informers/factory.go:87: watch of *v1.StorageClass ended with: The resourceVersion for the provided watch is too old.
W0904 02:59:45.524017       1 reflector.go:345] github.com/openshift/origin/vendor/k8s.io/kubernetes/pkg/controller/garbagecollector/graph_builder.go:125: watch of <nil> ended with: unexpected object: &{map[apiVersion:v1 metadata:map[] status:Failure message:The resourceVersion for the provided watch is too old. reason:Expired code:410 kind:Status]}
I0904 03:00:19.484883       1 reflector.go:343] github.com/openshift/origin/vendor/k8s.io/client-go/informers/factory.go:87: watch of *v1.LimitRange ended with: The resourceVersion for the provided watch is too old.
I0904 03:00:39.524936       1 reflector.go:343] github.com/openshift/origin/vendor/github.com/openshift/client-go/authorization/informers/externalversions/factory.go:58: watch of *v1.RoleBindingRestriction ended with: The resourceVersion for the provided watch is too old.
I0904 03:00:41.030556       1 reflector.go:343] github.com/openshift/origin/vendor/k8s.io/client-go/informers/factory.go:87: watch of *v1.LimitRange ended with: The resourceVersion for the provided watch is too old.
I0904 03:01:17.022047       1 reflector.go:343] github.com/openshift/origin/pkg/quota/generated/informers/internalversion/factory.go:58: watch of *quota.ClusterResourceQuota ended with: The resourceVersion for the provided watch is too old.
I0904 03:01:18.524285       1 reflector.go:343] github.com/openshift/origin/vendor/k8s.io/client-go/informers/factory.go:87: watch of *v1.PersistentVolumeClaim ended with: The resourceVersion for the provided watch is too old.

Comment 5 errata-xmlrpc 2019-09-10 23:59:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2688


Note You need to log in before you can comment on or make changes to this bug.