Bug 1731224 - newsboat tries to allocate 32 GiB of memory on startup
Summary: newsboat tries to allocate 32 GiB of memory on startup
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: newsboat
Version: 30
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jan Staněk
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-18 17:03 UTC by Frederik Holden
Modified: 2019-08-06 06:21 UTC (History)
2 users (show)

Fixed In Version: newsboat-latest-3020190722112326.a23e773d newsboat-latest-2920190722112326.c5ebb199
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-06 04:42:35 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github newsboat newsboat pull 584 'None' 'closed' 'Strip comments before the backticks are evaluated' 2019-11-20 12:05:22 UTC

Description Frederik Holden 2019-07-18 17:03:59 UTC
Description of problem:
After updating to 2.16.1, newsboat tries to allocate 32 GiB of memory when it's run, freezing up the computer because it's more than is available. This happens even with the sample configuration from /usr/share/doc/newsboat/examples/config, even though every line is either blank or commented out. It doesn't happen with a completely empty config, and I'm not sure what part of that config it is that's causing it.

Version-Release number of selected component (if applicable):
newsboat-2.16.1-1.module_f30+4957+96c82ecb.x86_64

How reproducible:
100%

Steps to Reproduce:
1. mkdir ~/.newsboat
2. cp /usr/share/doc/newsboat/examples/config ~/.newsboat
3. newsboat.

Actual results:
$ newsboat
Starting newsboat ...
Loading configuration...memory allocation of 34359738368 bytes failed

Expected results:
Not using so much memory.

Additional info:

Comment 1 Jan Staněk 2019-07-19 10:38:32 UTC
The 2.16.1 version contains a bug where the backticked shell-commands are evaluated *even in comments*. Since the example configuration contains multiple backticked values in it's comments (including several instances of `yes`, which will evaluate to infinite string), the newsboat crashes/hangs while trying to evaluate them.

See the linked PR for upstream bug report; once it is accepted, I will backport it to the Fedora package (or update to patched upstream version, whichever will be faster). In the mean time, you can work around the issue by removing any non-intentional backticked values from the newsboat configuration.

Thanks for the report!

Comment 2 Frederik Holden 2019-07-19 10:53:38 UTC
Well that explains why I was seeing "yes" in the process list. Good find, thanks so much!

Comment 3 Jan Staněk 2019-07-22 11:58:36 UTC
The newsboat-2.16.1-2 package is now built for Rawhide, and the module build is in progress.

Comment 4 Fedora Update System 2019-07-22 12:34:45 UTC
FEDORA-MODULAR-2019-4639a4ce6e has been submitted as an update to Fedora 30 Modular. https://bodhi.fedoraproject.org/updates/FEDORA-MODULAR-2019-4639a4ce6e

Comment 5 Fedora Update System 2019-07-23 02:24:39 UTC
newsboat-latest-3020190722112326.a23e773d has been pushed to the Fedora 30 Modular testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-MODULAR-2019-4639a4ce6e

Comment 6 Fedora Update System 2019-07-23 02:24:43 UTC
newsboat-latest-2920190722112326.c5ebb199 has been pushed to the Fedora 29 Modular testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-MODULAR-2019-764ec0caf8

Comment 7 Fedora Update System 2019-08-06 04:42:35 UTC
newsboat-latest-3020190722112326.a23e773d has been pushed to the Fedora 30 Modular stable repository. If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2019-08-06 06:21:32 UTC
newsboat-latest-2920190722112326.c5ebb199 has been pushed to the Fedora 29 Modular stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.