Bug 1731248 - rsyslog pod log spam
Summary: rsyslog pod log spam
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.2.0
Assignee: Noriko Hosoi
QA Contact: Eric Matysek
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-18 18:52 UTC by Eric Matysek
Modified: 2019-10-16 06:30 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 06:29:52 UTC
Target Upstream Version:


Attachments (Terms of Use)
rsyslog pod logs example (8.30 MB, application/gzip)
2019-07-18 18:52 UTC, Eric Matysek
no flags Details


Links
System ID Priority Status Summary Last Updated
Github https://github.com/openshift origin-aggregated-logging pull 1685 None None None 2019-07-25 21:33:52 UTC
Red Hat Product Errata RHBA-2019:2922 None None None 2019-10-16 06:30:07 UTC

Description Eric Matysek 2019-07-18 18:52:40 UTC
Created attachment 1591846 [details]
rsyslog pod logs example

Description of problem:
rsyslog container is outputting excessive logs

Version-Release number of selected component (if applicable):
4.2

How reproducible:
100%

Steps to Reproduce:
1. Deploy openshift-logging operator
2. oc exec -c rsyslog ${rsyslog_pod} -- logs | wc -l
3.

Actual results:
87073 lines after only ~15 mins

Expected results:
Only necessary/helpful logs to be output

Additional info:

Comment 1 Noriko Hosoi 2019-07-18 19:06:17 UTC
Yes, this is a known issue.  Will be fixed once this PR is merged.
https://github.com/openshift/origin-aggregated-logging/pull/1685

Comment 3 Eric Matysek 2019-08-06 16:35:16 UTC
Looks much better now

Comment 4 errata-xmlrpc 2019-10-16 06:29:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.