Bug 1731262 - kernel-headers-5.3.0-0.rc0.git5.1.fc31.s390x contains UAPI headers for x86-64
Summary: kernel-headers-5.3.0-0.rc0.git5.1.fc31.s390x contains UAPI headers for x86-64
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel-headers
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Justin M. Forbes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-18 19:45 UTC by Florian Weimer
Modified: 2019-07-29 11:57 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-29 11:57:36 UTC


Attachments (Terms of Use)

Description Florian Weimer 2019-07-18 19:45:24 UTC
In /usr/include/asm/unistd_64.h, there is:

#ifndef _ASM_X86_UNISTD_64_H
#define _ASM_X86_UNISTD_64_H 1

Comment 1 Laura Abbott 2019-07-18 20:45:47 UTC
Yes, this was my mistake. Upstream removed the target to generate all headers and I incorrectly recreated the script.

https://koji.fedoraproject.org/koji/taskinfo?taskID=36328729 should have all the appropriate headers. If it doesn't look right, let me know and I'll fix it up.

Comment 2 Laura Abbott 2019-07-19 15:13:48 UTC
I built the git7 kernel with the updated headers in the buildroot and it looked to be okay (it was failing with the bad headers previously)

Comment 3 DJ Delorie 2019-07-19 17:24:05 UTC
glibc builds are working now too


Note You need to log in before you can comment on or make changes to this bug.