Bug 1731269
| Summary: | VM creation fails with "insert operation not allowed when database server is in read only mode" | ||
|---|---|---|---|
| Product: | Red Hat OpenStack | Reporter: | David Hill <dhill> |
| Component: | openstack-neutron | Assignee: | Terry Wilson <twilson> |
| Status: | CLOSED CURRENTRELEASE | QA Contact: | Eran Kuris <ekuris> |
| Severity: | medium | Docs Contact: | |
| Priority: | urgent | ||
| Version: | 13.0 (Queens) | CC: | amuller, chrisw, jlibosva, nate.johnston, scohen |
| Target Milestone: | --- | Keywords: | Triaged, ZStream |
| Target Release: | --- | ||
| Hardware: | x86_64 | ||
| OS: | Linux | ||
| Whiteboard: | |||
| Fixed In Version: | puppet-tripleo-8.5.1-1.el7ost | Doc Type: | If docs needed, set a value |
| Doc Text: | Story Points: | --- | |
| Clone Of: | Environment: | ||
| Last Closed: | 2021-01-07 21:56:12 UTC | Type: | Bug |
| Regression: | --- | Mount Type: | --- |
| Documentation: | --- | CRM: | |
| Verified Versions: | Category: | --- | |
| oVirt Team: | --- | RHEL 7.3 requirements from Atomic Host: | |
| Cloudforms Team: | --- | Target Upstream Version: | |
| Embargoed: | |||
| Bug Depends On: | 1720947, 1757254 | ||
| Bug Blocks: | |||
This might be related to this other BZ ... https://bugzilla.redhat.com/show_bug.cgi?id=1724150 |
Description of problem: When creating lots of VMs, sometimes the following error message is encountered and VM creation errors: 2019-07-18 19:32:05.151 34 ERROR ovsdbapp.backend.ovs_idl.transaction [-] OVSDB Error: {"details":"insert operation not allowed when database server is in read only mode","error":"not allowed"}: RuntimeError: OVSDB Error: {"details":"update operation not allowed when database server is in read only mode","error":"not allowed"} 2019-07-18 19:32:05.151 34 ERROR ovsdbapp.backend.ovs_idl.transaction [req-44f89b8e-c647-41cb-bd62-9b62554a042e 70bfd15a9f9a3f32a589a3cfcbcb78886d3be060e961dd38048eef87870202a9 01b728e67a5a4d88b 655e5b3bc232450 - 0ef23cf14b4a4cecade7d9f1cee1862b 0ef23cf14b4a4cecade7d9f1cee1862b] Traceback (most recent call last): File "/usr/lib/python2.7/site-packages/ovsdbapp/backend/ovs_idl/connection.py", line 99, in run txn.results.put(txn.do_commit()) File "/usr/lib/python2.7/site-packages/ovsdbapp/backend/ovs_idl/transaction.py", line 115, in do_commit raise RuntimeError(msg) RuntimeError: OVSDB Error: {"details":"insert operation not allowed when database server is in read only mode","error":"not allowed"} 2019-07-18 19:32:05.152 34 ERROR neutron.plugins.ml2.managers [req-44f89b8e-c647-41cb-bd62-9b62554a042e 70bfd15a9f9a3f32a589a3cfcbcb78886d3be060e961dd38048eef87870202a9 01b728e67a5a4d88b655e5b3bc232450 - 0ef23cf14b4a4cecade7d9f1cee1862b 0ef23cf14b4a4cecade7d9f1cee1862b] Mechanism driver 'ovn' failed in create_port_postcommit: RuntimeError: OVSDB Error: {"details":"insert operation not allowed when database server is in read only mode","error":"not allowed"} 2019-07-18 19:32:05.152 34 ERROR neutron.plugins.ml2.managers Traceback (most recent call last): 2019-07-18 19:32:05.152 34 ERROR neutron.plugins.ml2.managers File "/usr/lib/python2.7/site-packages/neutron/plugins/ml2/managers.py", line 427, in _call_on_drivers 2019-07-18 19:32:05.152 34 ERROR neutron.plugins.ml2.managers getattr(driver.obj, method_name)(context) 2019-07-18 19:32:05.152 34 ERROR neutron.plugins.ml2.managers File "/usr/lib/python2.7/site-packages/networking_ovn/ml2/mech_driver.py", line 476, in create_port_postcommit 2019-07-18 19:32:05.152 34 ERROR neutron.plugins.ml2.managers self._ovn_client.create_port(port) 2019-07-18 19:32:05.152 34 ERROR neutron.plugins.ml2.managers File "/usr/lib/python2.7/site-packages/networking_ovn/common/ovn_client.py", line 350, in create_port 2019-07-18 19:32:05.152 34 ERROR neutron.plugins.ml2.managers self.add_txns_to_sync_port_dns_records(txn, port) 2019-07-18 19:32:05.152 34 ERROR neutron.plugins.ml2.managers File "/usr/lib64/python2.7/contextlib.py", line 24, in __exit__ 2019-07-18 19:32:05.152 34 ERROR neutron.plugins.ml2.managers self.gen.next() 2019-07-18 19:32:05.152 34 ERROR neutron.plugins.ml2.managers File "/usr/lib/python2.7/site-packages/networking_ovn/ovsdb/impl_idl_ovn.py", line 139, in transaction 2019-07-18 19:32:05.152 34 ERROR neutron.plugins.ml2.managers yield t 2019-07-18 19:32:05.152 34 ERROR neutron.plugins.ml2.managers File "/usr/lib64/python2.7/contextlib.py", line 24, in __exit__ 2019-07-18 19:32:05.152 34 ERROR neutron.plugins.ml2.managers self.gen.next() 2019-07-18 19:32:05.152 34 ERROR neutron.plugins.ml2.managers File "/usr/lib/python2.7/site-packages/ovsdbapp/api.py", line 102, in transaction 2019-07-18 19:32:05.152 34 ERROR neutron.plugins.ml2.managers del self._nested_txns_map[cur_thread_id] 2019-07-18 19:32:05.152 34 ERROR neutron.plugins.ml2.managers File "/usr/lib/python2.7/site-packages/ovsdbapp/api.py", line 59, in __exit__ 2019-07-18 19:32:05.152 34 ERROR neutron.plugins.ml2.managers self.result = self.commit() 2019-07-18 19:32:05.152 34 ERROR neutron.plugins.ml2.managers File "/usr/lib/python2.7/site-packages/ovsdbapp/backend/ovs_idl/transaction.py", line 62, in commit 2019-07-18 19:32:05.152 34 ERROR neutron.plugins.ml2.managers raise result.ex 2019-07-18 19:32:05.152 34 ERROR neutron.plugins.ml2.managers RuntimeError: OVSDB Error: {"details":"insert operation not allowed when database server is in read only mode","error":"not allowed"} 2019-07-18 19:32:05.152 34 ERROR neutron.plugins.ml2.managers Version-Release number of selected component (if applicable): Latest How reproducible: Sometimes Steps to Reproduce: 1. Create a bunch of VMs like 80 2. Rince and repeat until you hit that issue 3. Actual results: VM is in error Expected results: VM should be created Additional info: