Bug 1731270 - podman exec leaks an exec_pid_<hash> file for every exec in tmpfs [rhel-8.0.0.z]
Summary: podman exec leaks an exec_pid_<hash> file for every exec in tmpfs [rhel-8.0....
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: podman
Version: 8.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: 8.1
Assignee: Matthew Heon
QA Contact: atomic-bugs@redhat.com
URL:
Whiteboard:
Depends On: 1731117
Blocks: 1186913 1727325 1731268
TreeView+ depends on / blocked
 
Reported: 2019-07-18 20:13 UTC by Oneata Mircea Teodor
Modified: 2019-07-30 19:50 UTC (History)
15 users (show)

Fixed In Version: container-tools-rhel8-8000020190719142648.b1ada758
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1731117
Environment:
Last Closed: 2019-07-30 19:50:31 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:1956 None None None 2019-07-30 19:50:40 UTC

Comment 8 Joy Pu 2019-07-22 14:51:16 UTC
Can reproduced with podman-0.10.1.3-5.gitdb08685.el8+2131+7e3e9e07.x86_64, and test with podman-1.0.3-1.git9d78c0c.module+el8.0.0.z+3717+fdd07b7c.x86_64. The exec_pid_* files is not exist after the podman exec finished. So set this to verified. Details:
# podman run -d --name test busybox top
9b34c4cfdb4554f87b5eaa23a4c37b2837c49eac53203f245af389eda8d701e8
# podman exec test /bin/true
# podman exec test /bin/true
# podman exec test /bin/true
#  find /run/containers/storage -type f -iname 'exec_pid_*'

Comment 10 errata-xmlrpc 2019-07-30 19:50:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:1956


Note You need to log in before you can comment on or make changes to this bug.