Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1731312 - RemoteDeeplyNestedStackTest always fails because the hardcoded network name.
Summary: RemoteDeeplyNestedStackTest always fails because the hardcoded network name.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-heat-tests-tempest
Version: 14.0 (Rocky)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Rabi Mishra
QA Contact: Arik Chernetsky
URL:
Whiteboard:
Depends On: 1726471
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-19 04:27 UTC by Rabi Mishra
Modified: 2019-11-06 16:53 UTC (History)
3 users (show)

Fixed In Version: python-heat-tests-tempest-0.2.1-0.20180829061909.ecf121c.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1726471
Environment:
Last Closed: 2019-11-06 16:53:25 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:3747 0 None None None 2019-11-06 16:53:41 UTC

Description Rabi Mishra 2019-07-19 04:27:44 UTC
+++ This bug was initially created as a clone of Bug #1726471 +++

Description of problem:
RemoteDeeplyNestedStackTest always fails because the hardcoded network name.

An error log.
~~~
      File "/usr/lib/python2.7/site-packages/heatclient/common/http.py", line 320, in request
        raise exc.from_response(resp)
    heatclient.exc.HTTPBadRequest: ERROR: Parameter 'network_name' is invalid: Error validating value 'public': Unable to find network with name or id 'public'
~~~

Version-Release number of selected component (if applicable):
Current python-heat-test-tempest in RHOSP13 and upstream.

How reproducible:
Always

Steps to Reproduce:
1. Create a public network whose name is not 'public'.
2. Run the test.
3.

Actual results:
The test fails.

Expected results:
The test doesn't fail.

Additional info:
The issue occurs by the hardcoded network name in test_remote_deeply_nested.py.

--- Additional comment from Keigo Noha on 2019-07-04 06:54:20 UTC ---

Hi Rabi,

Thank you for your review in upstream.
The gerrit is now merged status. Would you be able to start the backport process into RHOSP13?

Best Regards,
Keigo Noha

--- Additional comment from Keigo Noha on 2019-07-19 00:12:31 UTC ---

Hi Rabi,

I'm sorry for interrupting you.
Would you proceed the backport into RHOSP13?

Kind Regards,
Keigo Noha

Comment 4 errata-xmlrpc 2019-11-06 16:53:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3747


Note You need to log in before you can comment on or make changes to this bug.