Bug 1731316 - Typo in the output of command `oc explain pv.spec.cinder`
Summary: Typo in the output of command `oc explain pv.spec.cinder`
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Storage
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.2.0
Assignee: Christian Huffman
QA Contact: Qin Ping
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-19 05:20 UTC by Liang Xia
Modified: 2019-10-16 06:30 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 06:30:08 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift origin pull 23534 None None None 2019-08-15 10:58:36 UTC
Red Hat Product Errata RHBA-2019:2922 None None None 2019-10-16 06:30:17 UTC

Description Liang Xia 2019-07-19 05:20:59 UTC
Description of problem:
Typo in the output of command `oc explain pv.spec.cinder`.
---
$ oc explain pv.spec.cinder
KIND:     PersistentVolume
VERSION:  v1

RESOURCE: cinder <Object>

DESCRIPTION:
     Cinder represents a cinder volume attached and mounted on kubelets host
     machine More info:
     https://releases.k8s.io/HEAD/examples/mysql-cinder-pd/README.md


Missing a "." before "More info:".



Version-Release number of selected component (if applicable):
4.2.0-0.nightly-2019-07-18-003042
Client Version: version.Info{Major:"4", Minor:"2+", GitVersion:"v4.2.0", GitCommit:"bbfcbc8ac", GitTreeState:"clean", BuildDate:"2019-07-18T06:28:31Z", GoVersion:"go1.12.6", Compiler:"gc", Platform:"linux/amd64"}
Server Version: version.Info{Major:"1", Minor:"14+", GitVersion:"v1.14.0+04ab1f0", GitCommit:"04ab1f0", GitTreeState:"clean", BuildDate:"2019-07-17T19:07:51Z", GoVersion:"go1.12.6", Compiler:"gc", Platform:"linux/amd64"}


How reproducible:
Always


Steps to Reproduce:
1.oc explain pv.spec.cinder


Actual results:
Check in description.


Expected results:
No typo.

Comment 2 Christian Huffman 2019-07-23 18:51:39 UTC
I've submitted a PR [1] to fix this in upstream.

[1] https://github.com/kubernetes/kubernetes/pull/80487

Comment 3 Christian Huffman 2019-08-01 20:56:15 UTC
Upstream PR has been merged, created [1] to backport this fix in origin.

[1] https://github.com/openshift/origin/pull/23534

Comment 5 Liang Xia 2019-08-15 23:26:10 UTC
Checked with below version, the issue still exist. May be the latest build does not contain the fix yet as the PR is merged several hours ago. QE will check again later.

$ rpm -q openshift-clients
openshift-clients-4.2.0-201908151419.git.0.c4dfe25.el7.x86_64

$ oc version --client
Client Version: version.Info{Major:"4", Minor:"2+", GitVersion:"v4.2.0", GitCommit:"c4dfe254f", GitTreeState:"clean", BuildDate:"2019-08-15T18:38:54Z", GoVersion:"go1.12.6", Compiler:"gc", Platform:"linux/amd64"}

$ oc explain pv.spec.cinder
KIND:     PersistentVolume
VERSION:  v1

RESOURCE: cinder <Object>

DESCRIPTION:
     Cinder represents a cinder volume attached and mounted on kubelets host
     machine More info:
     https://releases.k8s.io/HEAD/examples/mysql-cinder-pd/README.md

Comment 6 Chao Yang 2019-08-19 07:05:38 UTC
Update the bug status based on comment #5

Comment 10 Qin Ping 2019-08-27 06:01:58 UTC
Verified with:
$ oc version
Client Version: version.Info{Major:"4", Minor:"2+", GitVersion:"v4.2.0", GitCommit:"b985ea310", GitTreeState:"clean", BuildDate:"2019-08-26T22:29:09Z", GoVersion:"go1.12.8", Compiler:"gc", Platform:"linux/amd64"}
Server Version: version.Info{Major:"1", Minor:"14+", GitVersion:"v1.14.0+4f0c084", GitCommit:"4f0c084", GitTreeState:"clean", BuildDate:"2019-08-26T15:08:39Z", GoVersion:"go1.12.6", Compiler:"gc", Platform:"linux/amd64"}
OpenShift Version: 4.2.0-0.nightly-2019-08-26-202352

$ oc explain pv
KIND:     PersistentVolume
VERSION:  v1

DESCRIPTION:
     PersistentVolume (PV) is a storage resource provisioned by an
     administrator. It is analogous to a node. More info:
     https://kubernetes.io/docs/concepts/storage/persistent-volumes

Comment 11 errata-xmlrpc 2019-10-16 06:30:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.