Bug 1731319 - runtime error: "integer divide by zero" shows in Query Browser page if the time range is too small
Summary: runtime error: "integer divide by zero" shows in Query Browser page if the ti...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.2.0
Assignee: Andrew Pickering
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-19 05:37 UTC by Junqi Zhao
Modified: 2019-10-16 06:30 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 06:30:08 UTC
Target Upstream Version:


Attachments (Terms of Use)
runtime error: "integer divide by zero" (85.04 KB, image/png)
2019-07-19 05:37 UTC, Junqi Zhao
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 2197 None None None 2019-07-29 10:26:56 UTC
Red Hat Product Errata RHBA-2019:2922 None None None 2019-10-16 06:30:17 UTC

Description Junqi Zhao 2019-07-19 05:37:39 UTC
Created attachment 1591903 [details]
runtime error: "integer divide by zero"

Description of problem:
login cluster console as cluster-admin and go to Query Browser page, search one metrics and drag in the graph to zoom in the time range
if the time range is too small, there will be runtime error: "integer divide by zero" 

API from console
https://console-openshift-console.apps.qe-juzhao-fri.qe.devcluster.openshift.com/api/prometheus/api/v1/query_range?end=1563513453.24&start=1563513453.213&step=0.00008999999999999999&query=ALERTS&timeout=5s

# date --date='@1563513453.24'
Fri Jul 19 01:17:33 EDT 2019

# date --date='@1563513453.213'
Fri Jul 19 01:17:33 EDT 2019


Version-Release number of selected component (if applicable):
4.2.0-0.nightly-2019-07-18-120653

How reproducible:
Always

Steps to Reproduce:
1. See the description
2.
3.

Actual results:
runtime error: "integer divide by zero" if the time range is too small

Expected results:


Additional info:

Comment 2 Junqi Zhao 2019-08-01 08:42:11 UTC
the smallest time span is 10s if we drag and zoom in, even we set 1s in the dropdown list and drag to zoom in, the time span will be 10s. there is not runtime error now

payload: 4.2.0-0.nightly-2019-07-31-162901

Comment 3 errata-xmlrpc 2019-10-16 06:30:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.