Bug 1731320 - Include instructions for lvextend and xfs_growfs in Day2 tasks
Summary: Include instructions for lvextend and xfs_growfs in Day2 tasks
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation
Version: 3.11.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 3.11.z
Assignee: Bob Furu
QA Contact: Qin Ping
Vikram Goyal
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-19 05:41 UTC by Venkata Tadimarri
Modified: 2020-05-08 19:18 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-08 19:18:00 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Venkata Tadimarri 2019-07-19 05:41:11 UTC
Document URL: 

https://docs.openshift.com/container-platform/3.9/day_two_guide/docker_tasks.html#increasing-storage

Section Number and Name: 

Prerequisites -> Procedure -> After step 2

Describe the issue: 

The instructions are not complete or do not really cater for all scenarios where the increase in storage is not seen after running docker-storage-setup.

The doc covers thinpool based setups, but doesn't cover xfs/overlay2. 

Suggestions for improvement: 


Please add a note to run the following command in case the increas ein size is not visible because the chosen filesystem is xfs/overlay2

The logical volume can be grown to use all the available space in volume group by using below command.
If the requirement is to use lesser space, choose the percentage accordingly.
# lvextend -l +100%FREE /dev/mapper/docker_vol-dockerlv

The filesystem can then be grown to use this space by running. xfs volumes can not be shrunk.
# xfs_growfs /dev/mapper/docker_vol-dockerlv

4. The customer can substitute above commands with singl command as well:
# lvextend -r -l +100%FREE /dev/mapper/docker_vol-dockerlv

Comment 2 Stephen Cuppett 2019-11-21 12:56:02 UTC
OCP 3.6-3.10 is no longer on full support [1]. Marking un-triaged bugs CLOSED DEFERRED. If you have a customer case with a support exception or have reproduced on 3.11+, please reopen and include those details. When reopening, please set the Version to the appropriate version where reproduced.

[1]: https://access.redhat.com/support/policy/updates/openshift

Comment 3 Venkata Tadimarri 2019-11-26 22:38:25 UTC
Hi Stephen,

https://docs.openshift.com/container-platform/3.11/day_two_guide/docker_tasks.html

The same correction on the documentation applies for 3.11 as well. There is a mention of "The process may differ depending on the underlying OpenShift Container Platform infrastructure.". But this does not give the steps to fix it actually.

Comment 4 Bob Furu 2020-05-01 17:36:35 UTC
Created PR 21745 (https://github.com/openshift/openshift-docs/pull/21745) to add steps for XFS setups. 

Moving to QA. 

@Liang or @Ping - I'm unable to test on a 3.11 cluster, so hoping for QE assistance with targeted output (as indicated in PR comment: https://github.com/openshift/openshift-docs/pull/21745/files#r418630394). Thanks.

Comment 6 Bob Furu 2020-05-08 19:18:00 UTC
This has been merged and verified live in docs: https://docs.openshift.com/container-platform/3.11/day_two_guide/docker_tasks.html#increasing-storage
Closing BZ.


Note You need to log in before you can comment on or make changes to this bug.