Bug 1731346 - Incorrect VM/VM Template is removed from list view, when a VM/VM Template is deleted
Summary: Incorrect VM/VM Template is removed from list view, when a VM/VM Template is ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Container Native Virtualization (CNV)
Classification: Red Hat
Component: User Experience
Version: 2.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 2.1.0
Assignee: Filip Krepinsky
QA Contact: Radim Hrazdil
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-19 07:58 UTC by Radim Hrazdil
Modified: 2019-11-04 15:06 UTC (History)
4 users (show)

Fixed In Version: 4.2.0-0.nightly-2019-08-15-073735
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-04 15:06:24 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Radim Hrazdil 2019-07-19 07:58:16 UTC
Description of problem:
When user removes a VM or VM Template from list view, always the bottom VM/VM Template disappears from the list view regardless of which VM/VM Template user deletes.
The correct VM/VM Template is deleted, so the problem is only   

Version-Release number of selected component (if applicable):
Openshift/console commit: badfbbf97f37f56c340165a02e7b05512cbd7825

How reproducible:
100%

Steps to Reproduce:
1. Have at least 3 VMs (to prove that it is the most bottom VM disappearing, not +1 error)
2. Delete the first displayed VM
3.

Actual results:
The bottom VM disappears

Expected results:
The deleted VM should be deleted 

Additional info:
The same happens on VM Template After page refresh, correct list is displayed

Comment 1 Filip Krepinsky 2019-07-23 14:56:43 UTC
https://github.com/openshift/console/pull/2132

Comment 2 Radim Hrazdil 2019-08-20 13:43:36 UTC
Verified
INSTALLER_VERSION=4.2.0-0.nightly-2019-08-15-073735
HCO-v2.1.0-13


Note You need to log in before you can comment on or make changes to this bug.