Bug 1731470 - Need a way to automatically resolve gfid split-brains
Summary: Need a way to automatically resolve gfid split-brains
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: GlusterFS
Classification: Community
Component: replicate
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Karthik U S
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1593242
TreeView+ depends on / blocked
 
Reported: 2019-07-19 13:30 UTC by Karthik U S
Modified: 2020-03-12 14:23 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-12 14:23:26 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Gluster.org Gerrit 23078 0 None Abandoned TEST PATCH: gifd mismatch resolution - xattr setting 2020-05-13 19:30:30 UTC

Description Karthik U S 2019-07-19 13:30:20 UTC
Description of problem:

Gfid split-brain can occur due to one of the reasons mentioned in https://github.com/gluster/glusterfs/issues/502. At present this can be resolved either by using the CLI options or by manual intervention. There is no way to automatically resolve this situation. We need to have a way to do this without manual intervention.

Comment 1 Worker Ant 2019-07-19 13:34:11 UTC
REVIEW: https://review.gluster.org/23078 (TEST PATCH: gifd mismatch resolution - xattr setting) posted (#1) for review on master by Karthik U S

Comment 2 Worker Ant 2020-03-12 14:23:26 UTC
This bug is moved to https://github.com/gluster/glusterfs/issues/1035, and will be tracked there from now on. Visit GitHub issues URL for further details


Note You need to log in before you can comment on or make changes to this bug.