Bug 1731475 - Unable to use configure in rclone-browser
Summary: Unable to use configure in rclone-browser
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: rclone-browser
Version: 30
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Robert-André Mauchin
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-19 13:44 UTC by mielonka_z_redhata
Modified: 2019-07-20 16:50 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-20 16:50:53 UTC


Attachments (Terms of Use)

Description mielonka_z_redhata 2019-07-19 13:44:30 UTC
Description of problem:
Configure in rclone-browser is not working.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Run rclone-browser
2. Click configure button

Actual results:
Error with message about missing TERMINAL environment variable.


Expected results:
Terminal running configure command.


Additional info:
 I have only changed /usr/share/applications/rclone-browser.desktop file to cointain
Exec=env TERMINAL=/usr/bin/gnome-terminal /usr/bin/rclone-browser
instead of
Exec=/usr/bin/rclone-browser
and configure is working.

Comment 1 Robert-André Mauchin 2019-07-19 20:00:48 UTC
I can't set  the TERMINAL variable to /usr/bin/gnome-terminal because people choice of terminal emulators are varied. I, for example, don't have gnome-terminal even installed. You should define the TERMINAL environment variable to your preferred one in your ~/.bashrc or ~/.profile.

export TERMINAL=/usr/bin/gnome-terminal


You'll need to reload after the change.

Comment 2 mielonka_z_redhata 2019-07-20 16:50:53 UTC
Ok. I will set variable in shell profile. Thank for info.


Note You need to log in before you can comment on or make changes to this bug.