Bug 173148 - seuser segfaults on "show" command.
seuser segfaults on "show" command.
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: setools (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-14 12:24 EST by Stephen John Smoogen
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-14 13:04:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen John Smoogen 2005-11-14 12:24:32 EST
Description of problem:

seuser segfaults on command

[root@sadl23132 ~]# /usr/bin/seuser show root
Segmentation fault

Version-Release number of selected component (if applicable):

[root@sadl23132 ~]# rpm -q setools
setools-1.5.1-5

How reproducible:

100% on i386 systems using default policy from install.


Additional info:

execve("/usr/bin/seuser", ["/usr/bin/seuser", "show", "root"], [/* 21 vars */]) = 0
uname({sys="Linux", node="sadl23132.srn.sandia.gov", ...}) = 0
brk(0)                                  = 0x9a19000
access("/etc/ld.so.preload", R_OK)      = -1 ENOENT (No such file or directory)
open("/etc/ld.so.cache", O_RDONLY)      = 3
fstat64(3, {st_mode=S_IFREG|0644, st_size=86902, ...}) = 0
old_mmap(NULL, 86902, PROT_READ, MAP_PRIVATE, 3, 0) = 0xb7fea000
close(3)                                = 0
open("/lib/tls/libm.so.6", O_RDONLY)    = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\0S\305"..., 512) = 512
fstat64(3, {st_mode=S_IFREG|0755, st_size=178019, ...}) = 0
old_mmap(0xc52000, 139424, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 3, 0)
= 0xc52000
old_mmap(0xc73000, 8192, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x20000) = 0xc73000
close(3)                                = 0
open("/lib/libselinux.so.1", O_RDONLY)  = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\240\260"..., 512) = 512
fstat64(3, {st_mode=S_IFREG|0755, st_size=56320, ...}) = 0
old_mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0xb7fe9000
old_mmap(0x189000, 56172, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 3, 0)
= 0x189000
old_mmap(0x196000, 4096, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0xd000) = 0x196000
close(3)                                = 0
open("/lib/tls/libc.so.6", O_RDONLY)    = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\20\257"..., 512) = 512
fstat64(3, {st_mode=S_IFREG|0755, st_size=1454462, ...}) = 0
old_mmap(0xb26000, 1219772, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 3,
0) = 0xb26000
old_mmap(0xc4a000, 16384, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x124000) = 0xc4a000
old_mmap(0xc4e000, 7356, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0xc4e000
close(3)                                = 0
old_mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0xb7fe8000
mprotect(0xc4a000, 4096, PROT_READ)     = 0
mprotect(0xb1e000, 4096, PROT_READ)     = 0
set_thread_area({entry_number:-1 -> 6, base_addr:0xb7fe86c0, limit:1048575,
seg_32bit:1, contents:0, read_exec_only:0, limit_in_pages:1, seg_not_present:0,
useable:1}) = 0
munmap(0xb7fea000, 86902)               = 0
access("/etc/selinux/", F_OK)           = 0
brk(0)                                  = 0x9a19000
brk(0x9a3a000)                          = 0x9a3a000
open("/etc/selinux/config", O_RDONLY)   = 3
fstat64(3, {st_mode=S_IFREG|0644, st_size=448, ...}) = 0
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0xb7fff000
read(3, "# This file controls the state o"..., 4096) = 448
close(3)                                = 0
munmap(0xb7fff000, 4096)                = 0
open("/proc/mounts", O_RDONLY)          = 3
fstat64(3, {st_mode=S_IFREG|0444, st_size=0, ...}) = 0
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0xb7fff000
read(3, "rootfs / rootfs rw 0 0\n/proc /pr"..., 1024) = 562
close(3)                                = 0
munmap(0xb7fff000, 4096)                = 0
gettimeofday({1131989097, 576779}, NULL) = 0
getpid()                                = 4881
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
+++ killed by SIGSEGV +++
Process 4881 detached
Comment 1 Daniel Walsh 2005-11-14 13:04:14 EST
seuser is not of much use with the targeted policy since all users are in the
same role.

We know about this problem and have fixed it in the upstream version, (In the
latest setools, seuser is actually removed).  It is not currently considered a
problem that will be fixed in RHEL.

Note You need to log in before you can comment on or make changes to this bug.