Bug 1731480 - Navigating to a VM via URL is not working
Summary: Navigating to a VM via URL is not working
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.3.0
Assignee: Marek Libra
QA Contact: Radim Hrazdil
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-19 13:53 UTC by Radim Hrazdil
Modified: 2020-01-23 11:05 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Fixed loading of virtual machine detail page when accessed directly via URL
Clone Of:
Environment:
Last Closed: 2020-01-23 11:04:29 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 2147 'None' 'closed' 'Bug 1731480: Do not block "loaded" state on optional resources in Firehose' 2019-11-25 03:28:17 UTC
Red Hat Product Errata RHBA-2020:0062 None None None 2020-01-23 11:05:06 UTC

Description Radim Hrazdil 2019-07-19 13:53:17 UTC
Description of problem:
When navigating to a VM detail page via URL, the page remains blank.
There is followig error message in browser console:
GET http://localhost:9000/api/kubernetes/apis/kubevirt.io/v1alpha3/namespaces/test/virtualmachineinstances/example 404 (Not Found)

Version-Release number of selected component (if applicable):
2.1, (tested with openshift/console master, commit 0684689dd6206326967e564e32a3a1248398f723)

How reproducible:
100%

Steps to Reproduce:
1. Create a VM (let it be VM 'example' in namespace 'test')
2. Try to navigate to http://localhost:9000/k8s/ns/test/virtualmachines/example
3. 

Actual results:
VM detail page remains blank, error in browser console, see above

Expected results:

Additional info:
Navigation via Menu works OK.
Since we use navigating via URLs in our automation, we have no simple workaround

Comment 1 Radim Hrazdil 2019-07-22 11:38:37 UTC
Additional info 2: It only seems to happen when the VM is Off

Comment 2 Marek Libra 2019-07-24 11:17:19 UTC
Fix: https://github.com/openshift/console/pull/2147

Comment 3 Tomas Jelinek 2019-09-23 10:16:08 UTC
The patch has not been accepted by upstream on time.
The impact of this issue was only that it made the automated tests more complicated but it does not block them. Moving to the next release since it can not be merged past freeze so it can not make 2.1

Comment 4 Tomas Jelinek 2019-09-23 10:24:23 UTC
@Nelly, I can not move this out from 2.1, seems I don't have permissions for it. Can you please move it out based on Comment 3?

Comment 5 Nelly Credi 2019-09-23 13:01:28 UTC
We usually dont tolerate regression bugs between versions,
but in this case i really think it is reasonable 
i will lower the priority and adjust keywords

Comment 7 Guohua Ouyang 2019-11-25 03:31:23 UTC
verified on 4.3.0-0.nightly-2019-11-21-122827

Comment 9 errata-xmlrpc 2020-01-23 11:04:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.