Bug 1731518 - [abrt] dnssec-trigger: check_call(): subprocess.py:347:check_call:subprocess.CalledProcessError: Command '['unbound-control', 'flush_zone', '.']' returned non-zero exit status 1.
Summary: [abrt] dnssec-trigger: check_call(): subprocess.py:347:check_call:subprocess....
Keywords:
Status: CLOSED DUPLICATE of bug 1667388
Alias: None
Product: Fedora
Classification: Fedora
Component: dnssec-trigger
Version: 30
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Paul Wouters
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:aef5c81e3f1d4e556512a168048...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-19 15:34 UTC by Ashutosh
Modified: 2019-08-27 14:05 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-27 14:05:05 UTC


Attachments (Terms of Use)
File: backtrace (1.29 KB, text/plain)
2019-07-19 15:34 UTC, Ashutosh
no flags Details
File: cgroup (383 bytes, text/plain)
2019-07-19 15:34 UTC, Ashutosh
no flags Details
File: cpuinfo (1.47 KB, text/plain)
2019-07-19 15:34 UTC, Ashutosh
no flags Details
File: environ (1.82 KB, text/plain)
2019-07-19 15:34 UTC, Ashutosh
no flags Details
File: mountinfo (3.44 KB, text/plain)
2019-07-19 15:34 UTC, Ashutosh
no flags Details
File: namespaces (129 bytes, text/plain)
2019-07-19 15:34 UTC, Ashutosh
no flags Details
File: open_fds (840 bytes, text/plain)
2019-07-19 15:34 UTC, Ashutosh
no flags Details

Description Ashutosh 2019-07-19 15:34:38 UTC
Version-Release number of selected component:
dnssec-trigger-0.15-8.fc30

Additional info:
reporter:       libreport-2.10.1
cmdline:        /usr/bin/python3 -sE /usr/libexec/dnssec-trigger-script --update
crash_function: check_call
exception_type: subprocess.CalledProcessError
executable:     /usr/libexec/dnssec-trigger-script
interpreter:    python3-3.7.4-1.fc30.x86_64
kernel:         5.1.18-300.fc30.x86_64
runlevel:       N 5
type:           Python3
uid:            0

Truncated backtrace:
subprocess.py:347:check_call:subprocess.CalledProcessError: Command '['unbound-control', 'flush_zone', '.']' returned non-zero exit status 1.

Traceback (most recent call last):
  File "/usr/libexec/dnssec-trigger-script", line 748, in <module>
    main()
  File "/usr/libexec/dnssec-trigger-script", line 735, in main
    Application(sys.argv).run()
  File "/usr/libexec/dnssec-trigger-script", line 470, in run
    self.method()
  File "/usr/libexec/dnssec-trigger-script", line 632, in run_update
    self.run_update_global_forwarders()
  File "/usr/libexec/dnssec-trigger-script", line 655, in run_update_global_forwarders
    UnboundZoneConfig._control([config.flush_command, "."])
  File "/usr/libexec/dnssec-trigger-script", line 306, in _control
    subprocess.check_call(["unbound-control"] + args, stdout=DEVNULL, stderr=DEVNULL)
  File "/usr/lib64/python3.7/subprocess.py", line 347, in check_call
    raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command '['unbound-control', 'flush_zone', '.']' returned non-zero exit status 1.

Local variables in innermost frame:
popenargs: (['unbound-control', 'flush_zone', '.'],)
kwargs: {'stdout': <_io.BufferedWriter name='/dev/null'>, 'stderr': <_io.BufferedWriter name='/dev/null'>}
retcode: 1
cmd: ['unbound-control', 'flush_zone', '.']

Potential duplicate: bug 1667388

Comment 1 Ashutosh 2019-07-19 15:34:41 UTC
Created attachment 1591996 [details]
File: backtrace

Comment 2 Ashutosh 2019-07-19 15:34:43 UTC
Created attachment 1591997 [details]
File: cgroup

Comment 3 Ashutosh 2019-07-19 15:34:44 UTC
Created attachment 1591998 [details]
File: cpuinfo

Comment 4 Ashutosh 2019-07-19 15:34:46 UTC
Created attachment 1591999 [details]
File: environ

Comment 5 Ashutosh 2019-07-19 15:34:48 UTC
Created attachment 1592000 [details]
File: mountinfo

Comment 6 Ashutosh 2019-07-19 15:34:50 UTC
Created attachment 1592001 [details]
File: namespaces

Comment 7 Ashutosh 2019-07-19 15:34:51 UTC
Created attachment 1592002 [details]
File: open_fds

Comment 8 Paul Wouters 2019-08-27 14:05:05 UTC

*** This bug has been marked as a duplicate of bug 1667388 ***


Note You need to log in before you can comment on or make changes to this bug.