Bug 1731530 - Kubectl describe should check if kubectl describe prints relevant information for rc and pods
Summary: Kubectl describe should check if kubectl describe prints relevant information...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.2.0
Assignee: Maciej Szulik
QA Contact: zhou ying
URL:
Whiteboard: buildcop
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-19 17:08 UTC by Thomas Wiest
Modified: 2019-10-16 06:30 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 06:30:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2922 None None None 2019-10-16 06:30:35 UTC

Description Thomas Wiest 2019-07-19 17:08:05 UTC
[sig-cli] Kubectl client [k8s.io] Kubectl describe should check if kubectl describe prints relevant information for rc and pods [Conformance] [Suite:openshift/conformance/parallel/minimal] [Suite:k8s] expand_less	10s
fail [k8s.io/kubernetes/test/e2e/kubectl/kubectl.go:1005]: Unexpected error:
    <*errors.errorString | 0xc001f9f960>: {
        s: "could not parse pre-release/metadata (-master+$Format:%h$) in version \"v0.0.0-master+$Format:%h$\"",
    }
    could not parse pre-release/metadata (-master+$Format:%h$) in version "v0.0.0-master+$Format:%h$"
occurred


Full Log:
https://prow.svc.ci.openshift.org/view/gcs/origin-ci-test/pr-logs/pull/23420/pull-ci-openshift-origin-master-e2e-aws/11305

PR to fix:
https://github.com/openshift/oc/pull/18

Comment 1 Thomas Wiest 2019-07-19 17:14:40 UTC
> smarterclayton commented 2 hours ago
> Please make sure have a bug opened to track reverting this

This is the bug to track the revert.

Comment 2 Michal Fojtik 2019-07-24 10:14:00 UTC
Looks like the PR was merged, moving to QA.

Comment 3 zhou ying 2019-07-25 06:13:27 UTC
Confirmed with the latest version, the issue has fixed:4.2.0-0.nightly-2019-07-24-220922

Run logs: http://pastebin.test.redhat.com/783044

Comment 4 errata-xmlrpc 2019-10-16 06:30:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.