Bug 1731564 - Unable to query ironic inspector for data
Summary: Unable to query ironic inspector for data
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Kubernetes-native Infrastructure
Classification: Red Hat
Component: Management
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Ohad Levy
QA Contact: Arik Chernetsky
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-19 19:18 UTC by Alexander Chuzhoy
Modified: 2020-02-09 11:39 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-23 22:51:35 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Alexander Chuzhoy 2019-07-19 19:18:58 UTC
ironic inspector pod doesn't appear to be running on masters (and it's not available on provisionhost anymore).

Need to be able to query ironic inspector for introspection data.

[cloud-user@r640-u01 dev-scripts]$ OS_URL=http://openshift-master-2.qe1.kni.lab.eng.bos.redhat.com:5050 openstack baremetal introspection data save openshift-master-2
Unable to establish connection to http://openshift-master-2.qe1.kni.lab.eng.bos.redhat.com:5050: HTTPConnectionPool(host='openshift-master-2.qe1.kni.lab.eng.bos.redhat.com', port=5050): Max retries exceeded with url: / (Caused by NewConnectionError('<urllib3.connection.HTTPConnection object at 0x7f4c9474ee80>: Failed to establish a new connection: [Errno 111] Connection refused',))

[cloud-user@r640-u01 dev-scripts]$ for i in 0 1 2; do ssh core@openshift-master-${i}.qe1.kni.lab.eng.bos.redhat.com "hostname; sudo crictl ps -a|grep ironic"; done
openshift-master-0.qe1.kni.lab.eng.bos.redhat.com
bdcc410a35ecf quay.io/metal3-io/ironic-ipa-downloader@sha256:c304f982c1f677a0c715e5b98a97765d5331022bc7cf44a9936c70d62f2966e5 2 hours ago Exited ipa-downloader 0 ae0c1163c0542
openshift-master-1.qe1.kni.lab.eng.bos.redhat.com
openshift-master-2.qe1.kni.lab.eng.bos.redhat.com

Comment 1 Doug Hellmann 2019-08-23 22:51:35 UTC
The ironic-inspector service only listens on the provisioning network, so you will need to use the IP address of the pod on that network.


Note You need to log in before you can comment on or make changes to this bug.