Bug 1731766 - SELinux is preventing pmcd from 'read' accesses on the diretório pmdas.
Summary: SELinux is preventing pmcd from 'read' accesses on the diretório pmdas.
Keywords:
Status: CLOSED DUPLICATE of bug 1731760
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 30
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:72bb5431a4295ecb878d858a1a1...
: 1731762 1731763 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-21 21:45 UTC by alamar
Modified: 2019-07-23 14:09 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-23 14:09:13 UTC


Attachments (Terms of Use)

Description alamar 2019-07-21 21:45:16 UTC
Description of problem:
SELinux is preventing pmcd from 'read' accesses on the diretório pmdas.

*****  Plugin catchall (100. confidence) suggests   **************************

Se você acredita nisso pmcd deve ser permitido read acesso no pmdas directory por padrão.
Then você deve informar que este é um erro.
Você pode gerar um módulo de política local para permitir este acesso.
Do
permitir este acesso por agora executando: # ausearch -c 'pmcd'--raw | audit2allow -M my-pmcd # semodule -X 300 -i my-pmcd.pp

Additional Information:
Source Context                system_u:system_r:init_t:s0
Target Context                system_u:object_r:pcp_var_lib_t:s0
Target Objects                pmdas [ dir ]
Source                        pmcd
Source Path                   pmcd
Port                          <Desconhecido>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.14.3-41.fc30.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 5.1.18-300.fc30.x86_64 #1 SMP Mon
                              Jul 15 15:42:34 UTC 2019 x86_64 x86_64
Alert Count                   8
First Seen                    2019-07-21 14:23:31 -03
Last Seen                     2019-07-21 21:37:33 -03
Local ID                      5c06c287-2a8e-4ce1-8c55-936f24822868

Raw Audit Messages
type=AVC msg=audit(1563755853.726:251): avc:  denied  { read } for  pid=1660 comm="pmcd" name="pmdas" dev="dm-0" ino=1975100 scontext=system_u:system_r:init_t:s0 tcontext=system_u:object_r:pcp_var_lib_t:s0 tclass=dir permissive=0


Hash: pmcd,init_t,pcp_var_lib_t,dir,read

Version-Release number of selected component:
selinux-policy-3.14.3-41.fc30.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.10.1
hashmarkername: setroubleshoot
kernel:         5.1.18-300.fc30.x86_64
type:           libreport

Potential duplicate: bug 1317515

Comment 1 Lukas Vrabec 2019-07-22 08:59:50 UTC
*** Bug 1731763 has been marked as a duplicate of this bug. ***

Comment 2 Lukas Vrabec 2019-07-22 08:59:56 UTC
*** Bug 1731762 has been marked as a duplicate of this bug. ***

Comment 3 Lukas Vrabec 2019-07-23 14:09:13 UTC

*** This bug has been marked as a duplicate of bug 1731760 ***


Note You need to log in before you can comment on or make changes to this bug.