Bug 1731767 - SELinux is preventing ps from 'search' accesses on the diretório lightdm.
Summary: SELinux is preventing ps from 'search' accesses on the diretório lightdm.
Keywords:
Status: CLOSED DUPLICATE of bug 1731760
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 30
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:ff9cdecb8c29e758293aa4d6c0b...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-21 21:45 UTC by alamar
Modified: 2019-07-23 14:09 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-23 14:09:07 UTC


Attachments (Terms of Use)

Description alamar 2019-07-21 21:45:24 UTC
Description of problem:
SELinux is preventing ps from 'search' accesses on the diretório lightdm.

*****  Plugin catchall (100. confidence) suggests   **************************

Se você acredita nisso ps deve ser permitido search acesso no lightdm directory por padrão.
Then você deve informar que este é um erro.
Você pode gerar um módulo de política local para permitir este acesso.
Do
permitir este acesso por agora executando: # ausearch -c 'ps'--raw | audit2allow -M my-ps # semodule -X 300 -i my-ps.pp

Additional Information:
Source Context                system_u:system_r:pcp_pmie_t:s0
Target Context                system_u:object_r:xserver_log_t:s0
Target Objects                lightdm [ dir ]
Source                        ps
Source Path                   ps
Port                          <Desconhecido>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.14.3-41.fc30.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 5.1.18-300.fc30.x86_64 #1 SMP Mon
                              Jul 15 15:42:34 UTC 2019 x86_64 x86_64
Alert Count                   16
First Seen                    2019-07-21 11:25:02 -03
Last Seen                     2019-07-21 18:43:35 -03
Local ID                      6f62ea2d-9d72-4276-abe8-221a94e7e185

Raw Audit Messages
type=AVC msg=audit(1563745415.981:343): avc:  denied  { search } for  pid=9144 comm="ps" name="lightdm" dev="dm-0" ino=2108786 scontext=system_u:system_r:pcp_pmie_t:s0 tcontext=system_u:object_r:xserver_log_t:s0 tclass=dir permissive=0


Hash: ps,pcp_pmie_t,xserver_log_t,dir,search

Version-Release number of selected component:
selinux-policy-3.14.3-41.fc30.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.10.1
hashmarkername: setroubleshoot
kernel:         5.1.18-300.fc30.x86_64
type:           libreport

Potential duplicate: bug 1648603

Comment 1 Lukas Vrabec 2019-07-23 14:09:07 UTC

*** This bug has been marked as a duplicate of bug 1731760 ***


Note You need to log in before you can comment on or make changes to this bug.