Bug 1731801 - Use correct style for Create button on Deployment Config page
Summary: Use correct style for Create button on Deployment Config page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.2.0
Assignee: Jakub Hadvig
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-22 06:29 UTC by Yadan Pei
Modified: 2019-10-16 06:30 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 06:30:16 UTC
Target Upstream Version:


Attachments (Terms of Use)
CreateDeploymentButton (32.46 KB, image/png)
2019-07-22 06:30 UTC, Yadan Pei
no flags Details
CreateDeploymentConfigButton (35.81 KB, image/png)
2019-07-22 06:30 UTC, Yadan Pei
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 2110 None None None 2019-07-22 13:27:02 UTC
Red Hat Product Errata RHBA-2019:2922 None None None 2019-10-16 06:30:35 UTC

Description Yadan Pei 2019-07-22 06:29:28 UTC
Description of problem:


Version-Release number of selected component (if applicable):
4.2.0-0.nightly-2019-07-21-222447

How reproducible:
Always

Steps to Reproduce:
1. Users goes to Workloads -> Deployment Config, click Create
2. 
3.

Actual results:
1. There is only one option `From YAML` but the Create button is using class="pf-c-dropdown__toggle pf-c-dropdown__toggle"

Expected results:
1. If only `From YAML` is applicable/can be selected then we should eliminate and only leave the button as `Create`, so that we can use the same css style with other workloads creation button(blue button) `class="pf-c-button pf-m-primary"`


Additional info:
https://github.com/openshift/console/pull/2038

Comment 1 Yadan Pei 2019-07-22 06:30:26 UTC
Created attachment 1592521 [details]
CreateDeploymentButton

Comment 2 Yadan Pei 2019-07-22 06:30:48 UTC
Created attachment 1592522 [details]
CreateDeploymentConfigButton

Comment 3 Jakub Hadvig 2019-07-22 08:04:39 UTC
PR: https://github.com/openshift/console/pull/2110

Comment 5 Yadan Pei 2019-07-23 05:47:51 UTC
Create Deployment Config is now using correct class class="pf-c-button pf-m-primary"

Verified on 4.2.0-0.nightly-2019-07-23-002801

Comment 6 errata-xmlrpc 2019-10-16 06:30:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.