Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.

Bug 1731849

Summary: [machines] Disk failed to be created with iscsi-pool on Add Disk page
Product: Red Hat Enterprise Linux 8 Reporter: Xianghua Chen <xchen>
Component: cockpit-appstreamAssignee: Katerina Koukiou <kkoukiou>
Status: CLOSED ERRATA QA Contact: Xianghua Chen <xchen>
Severity: low Docs Contact:
Priority: unspecified    
Version: 8.1CC: mpitt, wshi, ymao, yunyang
Target Milestone: rcFlags: pm-rhel: mirror+
Target Release: 8.1   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-11-05 20:41:56 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Xianghua Chen 2019-07-22 08:21:25 UTC
Description of problem:
Disk failed to be created with iscsi-pool on Add Disk page, the iscsi-pool should be gray or the Create New should be gray when choosing iscsi-pool if it's expected not to create new disk with iscsi-pool.


Version-Release number of selected component (if applicable):
cockpit-machines-197-1.el8.noarch
libvirt-dbus-1.2.0-2.module+el8.1.0+2983+b2ae9c0a.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Prepare a iscsi-pool and add it in the Storage Pools
2. Prepare a VM, open the Disks tab, click Add Disk
3. Options as following:
Source: Create New
Pool: iscsi-pool
Name: test
Size: 1 GiB
4. Click Add


Actual results:
An error prompt:
Disk failed to be created
Error message: this function is not supported by the connection driver: storage pool does not support volume creation


Expected results:
The disk can be created or the iscsi-pool should be gray or the Create New should be gray when choosing iscsi-pool if it's expected not to create new disk with iscsi-pool.


Additional info:

Comment 1 Martin Pitt 2019-07-23 10:47:07 UTC
Fixed in https://github.com/cockpit-project/cockpit/pull/12388

Comment 3 Xianghua Chen 2019-08-05 08:09:07 UTC
Verified with package:
cockpit-machines-197.1-1.el8.noarch

Steps:
1. Prepare a iscsi-pool and add it in the Storage Pools
2. Prepare a VM, open the Disks tab, click Add Disk
3. Options as following:
Source: Create New
The Pool "iscsi-pool" now is gray and there is a hint saying :
This pool type does not support Storage Volume creation.

So verified.

Comment 5 errata-xmlrpc 2019-11-05 20:41:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3325