Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.

Bug 1731856

Summary: When Optional Legacy CA Is Not Present Error Will Be Created In Apache Log In CDS
Product: Red Hat Update Infrastructure for Cloud Providers Reporter: Martin Minar <mminar>
Component: CDSAssignee: Martin Minar <mminar>
Status: CLOSED ERRATA QA Contact: Radek Bíba <rbiba>
Severity: low Docs Contact:
Priority: unspecified    
Version: 3.1.1   
Target Milestone: 3.1.2   
Target Release: 3.1.x   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-09-12 13:23:38 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Martin Minar 2019-07-22 08:32:43 UTC
Description of problem:
Each content request is validated by oid validator against expected CAs. Since version 3.1 there is an optional CA that RHUI administrators can use called Legacy CA.
However if this legacy CA is not used function checking it will report error into Apache log even tho it is optional CA.

Version-Release number of selected component (if applicable):
rhui-oid-validator-3.0.1-1.el7ui.noarch

How reproducible:
On any machine without legacy CA.

Steps to Reproduce:
1. yum repolist from client
2. Check /var/log/httpd/ error.log

Actual results:
Contains several errors like: "[Mon Jul 22 08:27:10.631893 2019] [:error] [pid 19762] [client X.X.X.X:57644] Using a CA Chain with 1 cert(s)" followed by description of CA used to verify.

Expected results:
No error due to missing legacy CA.

Additional info:
Problem is in validator.py on line 88 - changing log function to None fixes the problem.

Comment 2 Martin Minar 2019-07-22 08:49:34 UTC
There is an error in description - this error manifest when there IS some legacy CA present in /etc/pki/rhui/legacy-ca/.

Comment 6 errata-xmlrpc 2019-09-12 13:23:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2757