Bug 1731873 - The page became blank when create instance on installed operator page
Summary: The page became blank when create instance on installed operator page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 4.2.0
Assignee: Alec Merdler
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-22 09:15 UTC by Yanping Zhang
Modified: 2019-10-16 06:30 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 06:30:16 UTC
Target Upstream Version:


Attachments (Terms of Use)
blankpage (134.09 KB, image/png)
2019-07-22 09:15 UTC, Yanping Zhang
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 2224 None None None 2019-07-31 00:32:06 UTC
Red Hat Product Errata RHBA-2019:2922 None None None 2019-10-16 06:30:35 UTC

Description Yanping Zhang 2019-07-22 09:15:58 UTC
Created attachment 1592552 [details]
blankpage

Description of problem:
 When create instance from intalled operator page with "Edit Form" model, the page will become blank.

Version-Release number of selected component (if applicable):
4.2.0-0.nightly-2019-07-21-222447

How reproducible:
Always

Steps to Reproduce:
1.Cluster admin installs operator on cluster, eg, etcd.
2.On "Installed Operators" page, "etcd" operator is intalled successfully(It may take several minutes).
3.Click into "etcd". Click "Create Instance" for "etcd Cluster". Click "Edit Form".
4.In name field, input "exampleetcd"

Actual results:
4. The page became blank when input the name field.
JS error:
TypeError: e.currentTarget is nullconfigure-update-strategy-modal.tsx:11


Expected results:
4. Should not become blank when input name.

Additional info:

Comment 1 Samuel Padgett 2019-07-31 00:31:36 UTC
https://github.com/openshift/console/pull/2224

Comment 3 Yadan Pei 2019-08-15 02:18:12 UTC
1.Cluster admin installs operator on cluster, eg, etcd.
2.On "Installed Operators" page, "etcd" operator is intalled successfully(It may take several minutes).
3.Click into "etcd". Click "Create Instance" for "etcd Cluster". Click "Edit Form".
4.In name field, edit the default name 'example' and change it to 'exampletest'
5.Set name with invalid values, hit Create will give error validation message 


Since the issue reported no longer exists, move to VERIFIED

4.2.0-0.nightly-2019-08-14-211610

Comment 4 errata-xmlrpc 2019-10-16 06:30:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.