Bug 173189 - Hotplug loading ibm_acpi ignores options in modprobe.conf
Summary: Hotplug loading ibm_acpi ignores options in modprobe.conf
Status: CLOSED DUPLICATE of bug 159120
Alias: None
Product: Fedora
Classification: Fedora
Component: hotplug   
(Show other bugs)
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-11-14 20:56 UTC by Andre Srinivasan
Modified: 2014-03-17 02:56 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-16 20:06:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andre Srinivasan 2005-11-14 20:56:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
I have the following in my modprobe.conf

options ibm_acpi experimental=1 hotkey=enable,0xffff

If I let hotplug load the module, the options are ignored.  If I add the module to the initial ramdisk image or load the module from rc.local, the options are picked up.



Version-Release number of selected component (if applicable):
2.6.14-1.1637_FC4

How reproducible:
Always

Steps to Reproduce:
0. Add options line from description to modprobe.conf
1. Boot standard FC4 distribution on Thinkpad.
2. Cat /proc/acpi/ibm/hotkey and note that its not enabled and the mask is not 0xfff
3. Add ibm_acpi to the initial ramdisk and reboot
4. Cat /proc/acpi/ibm/hotkey and note that its enabled and the mask is 0xffff
  

Additional info:

Comment 1 Bill Nottingham 2005-11-14 22:50:03 UTC
It's loaded with modprobe, so it *should* use the parameters. I'll have to do
some reproducing here.

Comment 2 Bill Nottingham 2005-11-16 20:06:41 UTC

*** This bug has been marked as a duplicate of 159120 ***


Note You need to log in before you can comment on or make changes to this bug.