Bug 1731908 - After upgrading gnome-shell, mutter and gnome-desktop3 to version 3.33.4-1 disappear login screen
Summary: After upgrading gnome-shell, mutter and gnome-desktop3 to version 3.33.4-1 di...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: BetaBlocker, F31BetaBlocker BetaFreezeException, F31BetaFreezeException
TreeView+ depends on / blocked
 
Reported: 2019-07-22 11:19 UTC by Mikhail
Modified: 2019-07-28 22:34 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-28 22:34:32 UTC


Attachments (Terms of Use)
system log (453.09 KB, text/plain)
2019-07-22 11:19 UTC, Mikhail
no flags Details

Description Mikhail 2019-07-22 11:19:07 UTC
Created attachment 1592558 [details]
system log

Description of problem:
After upgrading gnome-shell, mutter and gnome-desktop3 to version 3.33.4-1 disappear login screen
The only console is available.

Last workable versions:
  gnome-classic-session-3.33.3-1.fc31.noarch                                   
  gnome-desktop3-3.33.3-1.fc31.x86_64                                          
  gnome-shell-3.33.3-1.fc31.x86_64                                             
  gnome-shell-extension-apps-menu-3.33.3-1.fc31.noarch                         
  gnome-shell-extension-common-3.33.3-1.fc31.noarch                            
  gnome-shell-extension-launch-new-instance-3.33.3-1.fc31.noarch               
  gnome-shell-extension-places-menu-3.33.3-1.fc31.noarch                       
  gnome-shell-extension-window-list-3.33.3-1.fc31.noarch                       
  mutter-3.33.3-1.fc31.x86_64 

How reproducible:
All-time.

Steps to Reproduce:
Just upgrade system and reboot.

In system log I found follow lines:
Jul 22 15:06:17 localhost.localdomain kernel: show_signal_msg: 51 callbacks suppressed
Jul 22 15:06:17 localhost.localdomain kernel: gnome-shell[1327]: segfault at 8 ip 00007fa1923112fe sp 00007fff6faba160 error 6 in libgnome-desktop-3.so.18.0.0[7fa1922f7000+22000]
Jul 22 15:06:17 localhost.localdomain kernel: Code: 41 54 55 48 89 fd 53 e8 d0 90 fe ff 48 89 ef 48 89 c6 e8 05 9a fe ff 48 89 45 18 49 89 c4 e8 f9 a3 fe ff 48 8d 3d fb b1 00 00 <49> 89 44 24 08 48 8b 45 18 48 c7 40 10 00 00 00 00 e8 9c a0 fe ff

Comment 1 Fedora Blocker Bugs Application 2019-07-22 11:22:54 UTC
Proposed as a Blocker and Freeze Exception for 31-beta by Fedora user mikhail using the blocker tracking app because:

 Because the system became unusable.
Completely is broken Gnome GUI.

Comment 2 Yanko Kaneti 2019-07-22 13:15:47 UTC
Most likely a fallout of the libgnome-desktop soname bump and will clear up when everything is rebuilt with the new one

Comment 3 Adam Williamson 2019-07-26 21:03:31 UTC
Can you update all packages to latest Rawhide and report if you're still having trouble, Mikhail? Thanks! openQA tests are working right now...

Comment 4 Michael Catanzaro 2019-07-27 01:22:16 UTC
I think the problem is here:

# For temporary ABI compat
cp -a %{_libdir}/libgnome-desktop-3.so.17{,.*} $RPM_BUILD_ROOT%{_libdir}

And:
	
%{_libdir}/libgnome-desktop-3.so.17{,.*}
%{_libdir}/libgnome-desktop-3.so.18{,.*}

Having the lib installed twice probably causes trouble... we had a GNOME developer last week whose gnome-shell was unexpectedly using the .17 version when both were installed.

There's already been a mass rebuild so I'll just remove this. You'll have to report back whether it fixes the problem or not though.

Comment 5 Michael Catanzaro 2019-07-27 01:28:14 UTC
Please check if it's fixed by gnome-desktop3-3.33.4-3.fc31.

Comment 6 Mikhail 2019-07-28 22:18:38 UTC
Adam, a day after the issue happened I could successfully update the system with the following a set of packages.
It looks like some needed package is really missing in dependencies. And when this package is not upgraded issue happened.

=====================================================================================================
 Package                                     Architecture  Version                 Repository   Size
=====================================================================================================
Installing:
 kernel                                      x86_64        5.3.0-0.rc1.git0.1.fc31 rawhide      34 k
 kernel-core                                 x86_64        5.3.0-0.rc1.git0.1.fc31 rawhide      30 M
 kernel-modules                              x86_64        5.3.0-0.rc1.git0.1.fc31 rawhide      28 M
 kernel-modules-extra                        x86_64        5.3.0-0.rc1.git0.1.fc31 rawhide     2.1 M
Upgrading:
 anaconda                                    x86_64        31.20-1.fc31            rawhide     103 k
 anaconda-core                               x86_64        31.20-1.fc31            rawhide     2.1 M
 anaconda-gui                                x86_64        31.20-1.fc31            rawhide     445 k
 anaconda-install-env-deps                   x86_64        31.20-1.fc31            rawhide     103 k
 anaconda-live                               x86_64        31.20-1.fc31            rawhide     127 k
 anaconda-tui                                x86_64        31.20-1.fc31            rawhide     196 k
 anaconda-widgets                            x86_64        31.20-1.fc31            rawhide     137 k
 binutils                                    x86_64        2.32-18.fc31            rawhide     5.2 M
 binutils-gold                               x86_64        2.32-18.fc31            rawhide     861 k
 cheese                                      x86_64        2:3.32.1-2.fc31         rawhide     103 k
 cheese-libs                                 x86_64        2:3.32.1-2.fc31         rawhide     811 k
 dnf                                         noarch        4.2.7-2.fc31            rawhide     416 k
 dnf-data                                    noarch        4.2.7-2.fc31            rawhide      49 k
 eog                                         x86_64        3.33.3-2.fc31           rawhide     3.1 M
 evince                                      x86_64        3.32.0-7.fc31           rawhide     1.6 M
 evince-djvu                                 x86_64        3.32.0-7.fc31           rawhide      32 k
 evince-libs                                 x86_64        3.32.0-7.fc31           rawhide     376 k
 evince-nautilus                             x86_64        3.32.0-7.fc31           rawhide      20 k
 gamemode                                    x86_64        1.4-1.fc31              rawhide      86 k
 gnome-classic-session                       noarch        3.33.4-1.fc31           rawhide      34 k
 gnome-clocks                                x86_64        3.32.0-3.fc31           rawhide     389 k
 gnome-control-center                        x86_64        3.33.3-2.fc31           rawhide     5.5 M
 gnome-control-center-filesystem             noarch        3.33.3-2.fc31           rawhide     9.8 k
 gnome-desktop3                              x86_64        3.33.4-1.fc31           rawhide     591 k
 gnome-font-viewer                           x86_64        3.33.4-2.fc31           rawhide     198 k
 gnome-initial-setup                         x86_64        3.33.4-2.fc31           rawhide     1.3 M
 gnome-session                               x86_64        3.32.0-2.fc31           rawhide     388 k
 gnome-session-wayland-session               x86_64        3.32.0-2.fc31           rawhide      11 k
 gnome-session-xsession                      x86_64        3.32.0-2.fc31           rawhide      12 k
 gnome-settings-daemon                       x86_64        3.33.0-3.fc31           rawhide     1.0 M
 gnome-shell                                 x86_64        3.33.4-1.fc31           rawhide     1.4 M
 gnome-shell-extension-apps-menu             noarch        3.33.4-1.fc31           rawhide      16 k
 gnome-shell-extension-common                noarch        3.33.4-1.fc31           rawhide     144 k
 gnome-shell-extension-launch-new-instance   noarch        3.33.4-1.fc31           rawhide      11 k
 gnome-shell-extension-places-menu           noarch        3.33.4-1.fc31           rawhide      15 k
 gnome-shell-extension-window-list           noarch        3.33.4-1.fc31           rawhide      23 k
 google-noto-emoji-color-fonts               noarch        20190709-1.fc31         rawhide     8.7 M
 kernel-headers                              x86_64        5.3.0-0.rc1.git0.1.fc31 rawhide     1.1 M
 libdnf                                      x86_64        0.35.1-2.fc31           rawhide     612 k
 libgsf                                      x86_64        1.14.43-4.fc31          rawhide     247 k
 libhandy                                    x86_64        0.0.10-2.fc31           rawhide     126 k
 mutter                                      x86_64        3.33.4-2.fc31           rawhide     2.5 M
 pcre2                                       i686          10.33-9.fc31            rawhide     258 k
 pcre2                                       x86_64        10.33-9.fc31            rawhide     255 k
 pcre2-utf16                                 x86_64        10.33-9.fc31            rawhide     236 k
 pcre2-utf32                                 x86_64        10.33-9.fc31            rawhide     224 k
 podman                                      x86_64        2:1.4.5-0.29.dev.gitd6b4rawhide      12 M
 podman-manpages                             noarch        2:1.4.5-0.29.dev.gitd6b4rawhide     186 k
 python-pip-wheel                            noarch        19.1.1-3.fc31           rawhide     1.1 M
 python2-pip                                 noarch        19.1.1-3.fc31           rawhide     1.6 M
 python3-dnf                                 noarch        4.2.7-2.fc31            rawhide     396 k
 python3-hawkey                              x86_64        0.35.1-2.fc31           rawhide      98 k
 python3-libdnf                              x86_64        0.35.1-2.fc31           rawhide     728 k
 python3-pip                                 noarch        19.1.1-3.fc31           rawhide     1.6 M
 totem                                       x86_64        1:3.33.0-2.fc31         rawhide     1.3 M
Installing dependencies:
 gnome-shell-extension-horizontal-workspaces noarch        3.33.4-1.fc31           rawhide      10 k
Installing weak dependencies:
 libxcrypt-compat                            x86_64        4.4.6-2.fc31            rawhide      96 k
Removing:
 kernel                                      x86_64        5.3.0-0.rc0.git3.1.fc31 @anaconda     0  
 kernel-core                                 x86_64        5.3.0-0.rc0.git3.1.fc31 @anaconda    69 M
 kernel-modules                              x86_64        5.3.0-0.rc0.git3.1.fc31 @anaconda    29 M
 kernel-modules-extra                        x86_64        5.3.0-0.rc0.git3.1.fc31 @anaconda   2.1 M

Transaction Summary
=====================================================================================================

Comment 7 Michael Catanzaro 2019-07-28 22:34:32 UTC
OK, I assume that means it was already fixed before my change.


Note You need to log in before you can comment on or make changes to this bug.