Bug 1732088 - SELinux is preventing ps from using the 'sys_ptrace' capabilities.
Summary: SELinux is preventing ps from using the 'sys_ptrace' capabilities.
Keywords:
Status: CLOSED DUPLICATE of bug 1731760
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 30
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:60bdb90da38c3e9f56b9d3250f1...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-22 16:46 UTC by alamar
Modified: 2019-07-23 14:09 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-23 14:09:33 UTC


Attachments (Terms of Use)

Description alamar 2019-07-22 16:46:02 UTC
Description of problem:
SELinux is preventing ps from using the 'sys_ptrace' capabilities.

*****  Plugin catchall (100. confidence) suggests   **************************

Se você acredita nisso ps deve ter o sys_ptrace capacidade por padrão.
Then você deve informar que este é um erro.
Você pode gerar um módulo de política local para permitir este acesso.
Do
permitir este acesso por agora executando: # ausearch -c 'ps'--raw | audit2allow -M my-ps # semodule -X 300 -i my-ps.pp

Additional Information:
Source Context                system_u:system_r:pcp_pmlogger_t:s0
Target Context                system_u:system_r:pcp_pmlogger_t:s0
Target Objects                Desconhecido [ capability ]
Source                        ps
Source Path                   ps
Port                          <Desconhecido>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.14.3-41.fc30.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 5.1.18-300.fc30.x86_64 #1 SMP Mon
                              Jul 15 15:42:34 UTC 2019 x86_64 x86_64
Alert Count                   18
First Seen                    2019-07-22 11:30:05 -03
Last Seen                     2019-07-22 11:30:38 -03
Local ID                      980276c0-31e0-4f19-8f4c-4056e7caa88b

Raw Audit Messages
type=AVC msg=audit(1563805838.339:493): avc:  denied  { sys_ptrace } for  pid=30952 comm="ps" capability=19  scontext=system_u:system_r:pcp_pmlogger_t:s0 tcontext=system_u:system_r:pcp_pmlogger_t:s0 tclass=capability permissive=0


Hash: ps,pcp_pmlogger_t,pcp_pmlogger_t,capability,sys_ptrace

Version-Release number of selected component:
selinux-policy-3.14.3-41.fc30.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.10.1
hashmarkername: setroubleshoot
kernel:         5.1.18-300.fc30.x86_64
type:           libreport

Potential duplicate: bug 1396372

Comment 1 Lukas Vrabec 2019-07-23 14:09:33 UTC

*** This bug has been marked as a duplicate of bug 1731760 ***


Note You need to log in before you can comment on or make changes to this bug.