Bug 1732153 - Missing information about oc client version.
Summary: Missing information about oc client version.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 4.2.0
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
: 4.2.0
Assignee: Tomáš Nožička
QA Contact: zhou ying
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-22 19:31 UTC by Simon
Modified: 2019-10-16 06:30 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 06:30:26 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2922 None None None 2019-10-16 06:30:37 UTC

Description Simon 2019-07-22 19:31:07 UTC
Description of problem:

Missing information about oc version.

Version-Release number of selected component (if applicable):
4.2.0-0.nightly-2019-07-22-160516


How reproducible:
100%

Steps to Reproduce:
1. From page https://openshift-release.svc.ci.openshift.org/releasestream/4.2.0-0.nightly/release/4.2.0-0.nightly-2019-07-22-160516 download instaler

oc adm release extract --tools registry.svc.ci.openshift.org/ocp/release:4.2.0-0.nightly-2019-07-22-160516

2. Unpack files.
3. Get oc version:
# oc version -o yaml

Actual results:
clientVersion:
  buildDate: ""
  compiler: gc
  gitCommit: ""
  gitTreeState: ""
  gitVersion: unknown
  goVersion: go1.12.6
  major: ""
  minor: ""
  platform: linux/amd64


Expected results:
buildDate, gitCommit, gitTreeState, major, minor fields should be completed.

Additional info:
Not sure if this is in conflict with:
https://bugzilla.redhat.com/show_bug.cgi?id=1729610

Comment 1 Tomáš Nožička 2019-07-23 16:16:44 UTC
bump in https://github.com/openshift/oc/pull/23 is fixing those for ART builds

Comment 2 zhou ying 2019-07-25 03:24:24 UTC
Confirmed with latest version, the issue has fixed: 4.2.0-201907241419.git.0.bd34733.el7
clientVersion:
  buildDate: "2019-07-24T18:32:52Z"
  compiler: gc
  gitCommit: bd34733a7
  gitTreeState: clean
  gitVersion: v4.2.0
  goVersion: go1.12.6
  major: "4"
  minor: 2+
  platform: linux/amd64

Comment 3 errata-xmlrpc 2019-10-16 06:30:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.