Bug 1732164 - [marketplace] Report default operator source failings to telemetry
Summary: [marketplace] Report default operator source failings to telemetry
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: ---
: 4.2.0
Assignee: Alexander Greene
QA Contact: Fan Jia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-22 20:43 UTC by Alexander Greene
Modified: 2019-10-16 06:30 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 06:30:26 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github operator-framework operator-marketplace pull 222 None None None 2019-08-27 18:08:31 UTC
Github operator-framework operator-marketplace pull 246 None None None 2019-09-05 20:54:44 UTC
Github operator-framework operator-marketplace pull 253 None None None 2019-09-11 12:58:16 UTC
Red Hat Product Errata RHBA-2019:2922 None None None 2019-10-16 06:30:37 UTC

Description Alexander Greene 2019-07-22 20:43:10 UTC
Description of problem: If a default OperatorSource fails, the marketplace operator should report why the OperatorSource failed to telemetry.


Version-Release number of selected component (if applicable): 4.2


How reproducible: Always.


Steps to Reproduce:
1. Make marketplace unable to successfully reconcile one of the default OperatorSources.
2. Run `oc get ClusterOperator marketplace` and note that the status does not reflect that it has degraded.

Actual results: No information about the cause of the failure is available in telemetry.


Expected results: Telemetry should contain information about the cause of the failure.


Additional info:

Comment 3 Alexander Greene 2019-09-11 12:58:01 UTC
Adding a small change in https://github.com/operator-framework/operator-marketplace/pull/253

Comment 6 errata-xmlrpc 2019-10-16 06:30:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.