Bug 1732187 - Menus don't appear sometimes in konsole, okular, plasma-desktop in Plasma on Wayland with Qt 5.12.4
Summary: Menus don't appear sometimes in konsole, okular, plasma-desktop in Plasma on ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: qt5-qtwayland
Version: 30
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lubomir Rintel
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-23 01:13 UTC by Matt Fagnani
Modified: 2019-07-27 01:39 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-27 01:39:39 UTC


Attachments (Terms of Use)

Description Matt Fagnani 2019-07-23 01:13:44 UTC
Description of problem:

The right-click menu sometimes doesn't appear when I've right-clicked in konsole in Plasma 5.15.5 on Wayland with Qt 5.12.4. The message "konsole[2225]: qt.qpa.wayland: Non-toplevel surfaces can't request window states" happens when the right-click showed no menu. The journal contains messages such as the following when right-clicking in konsole and the right-click menu didn't appear.

Jul 22 19:57:58 plasmashell[1532]: qt.qpa.wayland.backingstore: Delivering update request through fallback timer, may not be in sync with display
Jul 22 19:57:58 plasmashell[1532]: qt.qpa.wayland.backingstore: Delivering update request through fallback timer, may not be in sync with display
Jul 22 19:57:58 plasmashell[1532]: qt.qpa.wayland.backingstore: Delivering update request through fallback timer, may not be in sync with display
Jul 22 19:57:59 plasmashell[1532]: qt.qpa.wayland: Non-toplevel surfaces can't request window states
Jul 22 19:57:59 plasmashell[1532]: QObject::startTimer: Timers cannot be started from another thread
Jul 22 19:57:59 plasmashell[1532]: qt.qpa.wayland.backingstore: Delivering update request through fallback timer, may not be in sync with display
Jul 22 19:57:59 plasmashell[1532]: qt.qpa.wayland: Non-toplevel surfaces can't request window states
Jul 22 19:58:00 plasmashell[1532]: qt.qpa.wayland.backingstore: Delivering update request through fallback timer, may not be in sync with display
Jul 22 19:58:00 plasmashell[1532]: qt.qpa.wayland.backingstore: Delivering update request through fallback timer, may not be in sync with display
Jul 22 19:58:07 plasmashell[1532]: kf5idletime_kwayland: This plugin does not support polling idle time
Jul 22 19:58:37 plasmashell[1532]: kf5idletime_kwayland: This plugin does not support polling idle time
Jul 22 19:58:38 konsole[2225]: qt.qpa.wayland: Non-toplevel surfaces can't request window states
Jul 22 19:58:39 plasmashell[1532]: qt.qpa.wayland.backingstore: Delivering update request through fallback timer, may not be in sync with display
Jul 22 19:58:44 plasmashell[1532]: qt.qpa.wayland.backingstore: Delivering update request through fallback timer, may not be in sync with display
Jul 22 19:59:07 plasmashell[1532]: kf5idletime_kwayland: This plugin does not support polling idle time
Jul 22 19:59:37 konsole[2225]: qt.qpa.wayland: Non-toplevel surfaces can't request window states
Jul 22 19:59:37 plasmashell[1532]: kf5idletime_kwayland: This plugin does not support polling idle time
Jul 22 19:59:40 konsole[2225]: qt.qpa.wayland: Non-toplevel surfaces can't request window states

The File, Edit and other menus in konsole have also showed nothing when I've clicked on them sometimes in Wayland. The same type of errors were in the journal when the File, Edit menus in konsole didn't appear.

Jul 22 20:52:58 plasmashell[1532]: qt.qpa.wayland.backingstore: Delivering update request through fallback timer, may not be in sync with display
Jul 22 20:53:07 plasmashell[1532]: kf5idletime_kwayland: This plugin does not support polling idle time
Jul 22 20:53:10 konsole[2225]: qt.qpa.wayland: Non-toplevel surfaces can't request window states
Jul 22 20:53:11 konsole[2225]: qt.qpa.wayland: Non-toplevel surfaces can't request window states
Jul 22 20:53:12 konsole[2225]: qt.qpa.wayland: Non-toplevel surfaces can't request window states


I've seen the same behaviour in okular and kate. Clicking on the File menu in kate which didn't appear was associated with the following journal messages.

Jul 22 21:08:01 plasmashell[1532]: qt.qpa.wayland: Non-toplevel surfaces can't request window states
Jul 22 21:08:04 plasmashell[1532]: qt.qpa.wayland.backingstore: Delivering update request through fallback timer, may not be in sync with display
Jul 22 21:08:05 kate[3485]: qt.qpa.wayland: Non-toplevel surfaces can't request window states
Jul 22 21:08:07 plasmashell[1532]: kf5idletime_kwayland: This plugin does not support polling idle time
Jul 22 21:08:09 plasmashell[1532]: qt.qpa.wayland.backingstore: Delivering update request through fallback timer, may not be in sync with display
Jul 22 21:08:09 plasmashell[1532]: qt.qpa.wayland: Non-toplevel surfaces can't request window states
Jul 22 21:08:09 plasmashell[1532]: QObject::startTimer: Timers cannot be started from another thread
Jul 22 21:08:10 plasmashell[1532]: qt.qpa.wayland.backingstore: Delivering update request through fallback timer, may not be in sync with display
Jul 22 21:08:11 plasmashell[1532]: qt.qpa.wayland: Non-toplevel surfaces can't request window states
Jul 22 21:08:11 plasmashell[1532]: qt.qpa.wayland.backingstore: Delivering update request through fallback timer, may not be in sync with display
Jul 22 21:08:37 plasmashell[1532]: kf5idletime_kwayland: This plugin does not support polling idle time
Jul 22 21:08:39 plasmashell[1532]: qt.qpa.wayland.backingstore: Delivering update request through fallback timer, may not be in sync with display
Jul 22 21:08:39 plasmashell[1532]: qt.qpa.wayland.backingstore: Delivering update request through fallback timer, may not be in sync with display
Jul 22 21:08:40 plasmashell[1532]: qt.qpa.wayland.backingstore: Delivering update request through fallback timer, may not be in sync with display
Jul 22 21:08:40 plasmashell[1532]: qt.qpa.wayland.backingstore: Delivering update request through fallback timer, may not be in sync with display
Jul 22 21:08:42 plasmashell[1532]: qt.qpa.wayland.backingstore: Delivering update request through fallback timer, may not be in sync with display
Jul 22 21:08:43 plasmashell[1532]: qt.qpa.wayland: Non-toplevel surfaces can't request window states
Jul 22 21:08:43 plasmashell[1532]: QObject::startTimer: Timers cannot be started from another thread
Jul 22 21:08:44 plasmashell[1532]: qt.qpa.wayland.backingstore: Delivering update request through fallback timer, may not be in sync with display
Jul 22 21:08:44 plasmashell[1532]: qt.qpa.wayland.backingstore: Delivering update request through fallback timer, may not be in sync with display
Jul 22 21:08:44 plasmashell[1532]: qt.qpa.wayland.backingstore: Delivering update request through fallback timer, may not be in sync with display
Jul 22 21:08:44 plasmashell[1532]: qt.qpa.wayland: Non-toplevel surfaces can't request window states



Right-clicking on the Plasma desktop on Wayland also doesn't show the right-click menu sometimes.

Version-Release number of selected component (if applicable):
kate-0:19.04.2-1.fc30.x86_64
kf5-kwayland-0:5.59.0-2.fc30.x86_64
konsole5-0:19.04.2-1.fc30.x86_64
okular-0:18.12.2-1.fc30.x86_64
plasma-desktop-0:5.15.5-1.fc30.x86_64
qt5-qtbase-0:5.12.4-3.fc30.x86_64
qt5-qtwayland-0:5.12.4-4.fc30.x86_64


How reproducible:
The menus not showing up has happened about 30-50% of the times I've tried to right-click or select File, Edit menus in konsole, okular, and kate.

Steps to Reproduce:
1. Boot F30 KDE spin fully updated with updates-testing enabled
2. log in to Plasma on Wayland from sddm
3. start konsole
4. right click in the main part of the konsole windows many times
5. select the File, Edit, menus in konsole many times
6. journalctl -b

Actual results:
The right-click and File, Edit menus in konsole sometimes haven't appeared on Wayland

Expected results:
The menus appeared normally.

Additional info:

https://bugs.kde.org/show_bug.cgi?id=409104 involved the `
qt.qpa.wayland: Non-toplevel surfaces can't request window states
message with spectacle. The patch for qtwayland at https://codereview.qt-project.org/c/qt/qtwayland/+/265999 might address this problem according to https://bugs.kde.org/show_bug.cgi?id=409104#c5

I haven't seen this problem in Plasma on X. This problem seemed to start with Qt 5.12.4. The issue seems more common after the qt5-qtbase-5.12.4-3
qt5-qtwayland-5.12.4-4 update https://bodhi.fedoraproject.org/updates/FEDORA-2019-6a476fd9b1

Comment 1 Fedora Update System 2019-07-23 07:11:11 UTC
FEDORA-2019-dd122cc792 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-dd122cc792

Comment 2 Jan Grulich 2019-07-23 07:12:02 UTC
Ups, I seem to push older version of qt5-qtbase to updates then I intended. Can you try with qt5-qtbase-0:5.12.4-4.fc30.x86_64?

Comment 3 Fedora Update System 2019-07-24 01:41:58 UTC
qt5-qtbase-5.12.4-4.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-dd122cc792

Comment 4 Fedora Update System 2019-07-27 01:39:39 UTC
qt5-qtbase-5.12.4-4.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.