This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 173229 - anaconda crashes after choosing custom resolution
anaconda crashes after choosing custom resolution
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rhpxl (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Chris Lumens
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-15 09:00 EST by Stefan Geuns
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-02 11:08:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Stefan Geuns 2005-11-15 09:00:21 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
Boot the latest boot.iso with these commandline options:
linux graphical resolution=1400x1050

I get the error as shown below and the installer quits. 

Version-Release number of selected component (if applicable):
anaconda-10.89.12-1

How reproducible:
Always

Steps to Reproduce:
1. boot boot.iso
2. type: linux graphical resolution=1400x1050
3. select http and wait until graphical part starts
  

Actual Results:  Installer crashed while starting

Expected Results:  Installer should have started in graphical mode.

Additional info:

File "/usr/bin/anaconda", line 963, in ?
runres_override
File "/usr/lib/python2.4/site-packages/rhpxl/xhwstate.py", line 154, in get_valid_resolution
xcfg = xhwstate.XF86.HardwareState(defcard=videohw, defmon=monitorhw)
NameError: Global name 'xhwstate' is not defined

I'm running in vmware 5.5 beta 2 (build 18007)
I made an IDE HD of 6 GB.
Videocard outside vmware is a ati x300 mobile and screen support resolution up to 1400x1050. vmware supports this too, because I had core 4 running before.
If I don't enter the resolution= part, then the installer starts as normal.
Comment 1 Chris Lumens 2005-11-15 10:17:57 EST
Please try tomorrow and let me know if it works for you.
Comment 2 Stefan Geuns 2005-11-17 12:23:38 EST
Works now. 
Would it be possible to enlarge the installation area instead of using the
brownish background?
Comment 3 Chris Lumens 2005-12-02 11:08:02 EST
We only really have images that work at the regular resolution and the lowres
version, so it'd probably look pretty weird if we made the installation area larger.

Note You need to log in before you can comment on or make changes to this bug.