Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1732299 - Only one container's volume is list in "Volumes" part on detail page after attach storage to all containers
Summary: Only one container's volume is list in "Volumes" part on detail page after at...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.2.0
Assignee: Zac Herman
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-23 06:51 UTC by Yanping Zhang
Modified: 2019-10-16 06:30 UTC (History)
5 users (show)

Fixed In Version: 4.2
Doc Type: Bug Fix
Doc Text:
Cause: Volume Tables were written in parallel with handling individual containers when attaching storage. They were not tested together and there was an issue when displaying each individual volume per container. Consequence: Only the last container's volume showed in the table if the same volume name was used (over wrote the prior ones since name was not unique) Fix: Properly index all volumes per container using volume name and container name as the key so all they show in the table. Result: Every volume now shows for all containers
Clone Of:
Environment:
Last Closed: 2019-10-16 06:30:44 UTC
Target Upstream Version:


Attachments (Terms of Use)
volumes-in-yaml (58.08 KB, image/png)
2019-07-23 06:51 UTC, Yanping Zhang
no flags Details
volumes-in-table (12.13 KB, image/png)
2019-07-23 06:51 UTC, Yanping Zhang
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 2138 0 None None None 2019-07-23 19:02:24 UTC
Red Hat Product Errata RHBA-2019:2922 0 None None None 2019-10-16 06:30:59 UTC

Description Yanping Zhang 2019-07-23 06:51:20 UTC
Created attachment 1592756 [details]
volumes-in-yaml

Description of problem:
When attach storage to dc, choose to "use all containers", but only one volume is listed for the last container in "Volumes" part on the dc detail page.

Version-Release number of selected component (if applicable):
4.2.0-0.nightly-2019-07-23-002801

How reproducible:
Always

Steps to Reproduce:
1.Create dc with multiple containers in project.
2.Add storage to the dc, and choose "use all containers", click "Save". Check volumes.
3.

Actual results:
2. There are volumes for all containers in yaml. But only the last container's volume is shown in the "Volumes" part on the dc detail page. Refer to attachments。

Expected results:
3. Should show volumes for all containers.

Additional info:

Comment 1 Yanping Zhang 2019-07-23 06:51:52 UTC
Created attachment 1592757 [details]
volumes-in-table

Comment 2 Jakub Hadvig 2019-07-23 11:17:57 UTC
The Volumes table is showing all the claims that are mounted into any of the containers. 
Since you created a single claim and attached it to all the containers it's still just 
one PVC. The table is not showing the PVC's per container since in this case it would be a duplicate.

One thing that the table could show is all the containers that the PVC is attached to,
to make things more clear.

Sam what do you think ?

Comment 3 Samuel Padgett 2019-07-23 12:23:25 UTC
Yes, the table show be showing all containers. This is a bug.

Comment 4 Zac Herman 2019-07-23 18:53:41 UTC
Opened PR 2138 https://github.com/openshift/console/pull/2138 to address this.

Comment 6 Yanping Zhang 2019-07-25 03:27:46 UTC
4.2.0-0.nightly-2019-07-24-220922
console image: quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:d2e7b52b23c5755d0aa8e47e848049c188400e575a8678e175bd03130f4c766c
https://github.com/openshift/console/commit/1c78f00ce5e2a313e4dd673df240e438438d45b6
Checked on ocp 4.2 with above version, now volumes for all containers are listed in "Volumes" table. The bug has been fixed.

Comment 7 errata-xmlrpc 2019-10-16 06:30:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.