Bug 1732300 - Wrong command format to create PVC in local storage example uage
Summary: Wrong command format to create PVC in local storage example uage
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Storage
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.2.0
Assignee: Hemant Kumar
QA Contact: Liang Xia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-23 06:53 UTC by Liang Xia
Modified: 2019-10-16 06:30 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 06:30:44 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2922 None None None 2019-10-16 06:30:59 UTC

Description Liang Xia 2019-07-23 06:53:31 UTC
Description of problem:
https://github.com/openshift/local-storage-operator/blob/master/docs/deploy-with-olm.md#example-usage
The command format used to create PVC is incorrect


Version-Release number of selected component (if applicable):
4.2

How reproducible:
Always

Steps to Reproduce:
1.Go to https://github.com/openshift/local-storage-operator/blob/master/docs/deploy-with-olm.md#example-usage and check the steps used to create PVC.

Actual results:
---
<< EOF | oc create -f -
kind: PersistentVolumeClaim
apiVersion: v1
metadata:
  name: example-local-claim
spec:
  accessModes:
  - ReadWriteOnce
  resources:
    requests:
      storage: 100Gi 
  storageClassName: local-sc
EOF


Expected results:
The correct format should be,
---
oc create -f - << EOF
kind: PersistentVolumeClaim
apiVersion: v1
metadata:
  name: example-local-claim
spec:
  accessModes:
  - ReadWriteOnce
  resources:
    requests:
      storage: 100Gi 
  storageClassName: local-sc
EOF

Comment 2 Liang Xia 2019-07-24 07:18:09 UTC
QE have verified that the command is fixed.

https://github.com/openshift/local-storage-operator/blob/master/docs/deploy-with-olm.md#example-usage
oc create -f - << EOF
kind: PersistentVolumeClaim
apiVersion: v1
metadata:
  name: example-local-claim
spec:
  accessModes:
  - ReadWriteOnce
  resources:
    requests:
      storage: 100Gi 
  storageClassName: local-sc
EOF

Comment 4 Liang Xia 2019-07-29 04:55:30 UTC
Move to verified according to #comment 2

Comment 5 errata-xmlrpc 2019-10-16 06:30:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.