Bug 1732306 - libvirt metadata function is broken
Summary: libvirt metadata function is broken
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Virtualization Tools
Classification: Community
Component: libvirt
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Michal Privoznik
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-23 07:08 UTC by Jules
Modified: 2019-08-05 19:21 UTC (History)
4 users (show)

Fixed In Version: libvirt-5.7.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-05 19:21:53 UTC


Attachments (Terms of Use)

Description Jules 2019-07-23 07:08:15 UTC
Description of problem:
when trying to use virsh metadata i get error: this function is not supported by the connection driver: virDomainGetMetadata

Version-Release number of selected component (if applicable):
libvirt 5.5.0

How reproducible:
100%

Steps to Reproduce:
virsh metadata yourVM http://libvirt.org/schemas/console-proxy/1.0

Actual results:
error: this function is not supported by the connection driver: virDomainGetMetadata

Expected results:
No Error

Additional info:

Comment 1 Peter Krempa 2019-07-23 07:15:53 UTC
What hypervisor driver are you using? Not every driver implements that function currently.

Look for virDomainGetMetadata in https://libvirt.org/hvsupport.html

Comment 2 Jules 2019-07-23 08:30:04 UTC
Ahh. Now that makes sense.

I use libxl driver. 
But whats the trouble in allowing this for all drivers. Since its just metadata?

Comment 3 Daniel Berrangé 2019-07-23 08:40:58 UTC
There's no reason why it can't be implemented, it is simply a matter of someone having the time to write the code  & submit it.

Comment 4 Jules 2019-07-23 13:30:48 UTC
Till then, is there any workaround to use your console-proxy?

Thanks in advance!

Comment 5 Daniel Berrangé 2019-07-23 13:32:50 UTC
In general you probably shouldn't use the console proxy as while the idea is great, I can't claim the impl is finished / production ready

It was however designed to have a pluggable backend - the backend that uses the metadata was just a simple example one. It is easy to come up with other backends

Comment 6 Michal Privoznik 2019-08-05 08:54:26 UTC
Patch proposed upstream:

https://www.redhat.com/archives/libvir-list/2019-August/msg00094.html

Comment 7 Jules 2019-08-05 14:16:07 UTC
You are awesome. Thanks!

Is there any fund e.g. to send tip to the dev team?

Comment 8 Michal Privoznik 2019-08-05 19:21:53 UTC
Pushed upstream as v5.6.0-4-g0f68e1c9ba.

(In reply to Jules from comment #7)
> You are awesome. Thanks!
> 
> Is there any fund e.g. to send tip to the dev team?

No, but don't worry about it.


Note You need to log in before you can comment on or make changes to this bug.