This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 173232 - Allow alternative frontends
Allow alternative frontends
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: usermode (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
David Lawrence
:
Depends On:
Blocks: Yellowpad 170837
  Show dependency treegraph
 
Reported: 2005-11-15 09:22 EST by Matthias Clasen
Modified: 2013-07-02 19:11 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-15 15:33:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
accept gecos information on the commandline (2.44 KB, patch)
2005-11-15 09:22 EST, Matthias Clasen
no flags Details | Diff

  None (edit)
Description Matthias Clasen 2005-11-15 09:22:05 EST
We want to switch to the about me capplet which is in upstream control-center
since 2.12, which will allow us to replace 3 of our homegrown capplets (login
photo, password and about myself). To do this properly,  we need to be able to
use the userhelper mechanism to update the gecos information. 

Since userhelper_runv() is not available in a library, the next best way to
achieve this in a nonintrusive way is to make userinfo accept the gecos data on
the commandline, and not open the dialog in that case.

The attached patch does that.
Comment 1 Matthias Clasen 2005-11-15 09:22:05 EST
Created attachment 121064 [details]
accept gecos information on the commandline
Comment 2 Jindrich Novy 2005-11-15 15:33:38 EST
Applied since 1.83-1.

Note You need to log in before you can comment on or make changes to this bug.