Bug 1732389 - Cannot preserve old DNS config when applying empty state
Summary: Cannot preserve old DNS config when applying empty state
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: nmstate
Version: 8.1
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: 8.1
Assignee: Gris Ge
QA Contact: Mingyu Shi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-23 09:31 UTC by Gris Ge
Modified: 2019-11-05 20:52 UTC (History)
2 users (show)

Fixed In Version: nmstate-0.0.8-1.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-05 20:51:59 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:3347 None None None 2019-11-05 20:52:13 UTC

Description Gris Ge 2019-07-23 09:31:50 UTC
Description of problem:

When applying empty state, the nmstate will move the DNS config to the default gateway interface instead of preserving old DNS config savings.

Version-Release number of selected component (if applicable):
nmstate-0.0.7-1.el8

How reproducible:
100%


Steps to Reproduce:
1. Use nmcli to save a DNS entry in a non-default gateway interface.
2. Create `empty.yml` with below content:

---
interfaces: []

3. sudo nmstatectl set empty.yml

Actual results:

The DNS config moved to the interface with default gateway.

Expected results:

The old DNS config been preserved.

Additional info:
Upstream fix is a87f03dc7b8377340da9c20b82344bbf9d1933c0

Comment 4 errata-xmlrpc 2019-11-05 20:51:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3347


Note You need to log in before you can comment on or make changes to this bug.