Bug 1732433 - [3.10] Fail to retrieve images from stage registry, got x509 errors
Summary: [3.10] Fail to retrieve images from stage registry, got x509 errors
Keywords:
Status: CLOSED DUPLICATE of bug 1696113
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Service Broker
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.10.z
Assignee: Shawn Hurley
QA Contact: Zhang Cheng
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-23 11:35 UTC by Jian Zhang
Modified: 2019-07-23 11:53 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-23 11:53:40 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jian Zhang 2019-07-23 11:35:14 UTC
Description of problem:
As title, got below errors:
[2019-07-23T11:06:35.775Z] [WARNING] - registry: 0x15848a0 was unable to complete bootstrap - Get https://registry.access.stage.redhat.com/v1/search?q="*-apb": x509: certificate signed by unknown authority
[2019-07-23T11:06:35.775Z] [ERROR] - Failed to bootstrap on startup!
[2019-07-23T11:06:35.775Z] [ERROR] - all registries failed on bootstrap

Version-Release number of selected component (if applicable):
3.10.z

How reproducible:
always

Steps to Reproduce:
1. Config the registry in ASB configmap, as below:
registry:
  - type: rhcc
    name: rh
    url:  https://registry.access.stage.redhat.com
    org:  
    tag:  v3.10.153
    white_list:
    - openshift3/mediawiki-apb
    - openshift3/postgresql-apb
    - openshift3/mariadb-apb
    - openshift3/mysql-apb
    skip_verify_tls: true      
    auth_type: ""
    auth_name: ""

2. Reload the updated configmap, as below:
# oc rollout latest dc/asb

3. Check the ASB pods.
[root@qe-smoke310-master-etcd-1 ~]# oc get pods
NAME           READY     STATUS             RESTARTS   AGE
asb-1-wr89z    0/1       CrashLoopBackOff   3          1m
asb-3-deploy   1/1       Running            0          1m
asb-3-t86cv    0/1       CrashLoopBackOff   3          1m

Actual results:
Pods failed to run.

Expected results:
The ASB can retrieve stage images successfully.

Additional info:
ASB pods logs:
[root@qe-smoke310-master-etcd-1 ~]# oc logs asb-3-t86cv
Using config file mounted to /etc/ansible-service-broker/config.yaml
============================================================
==           Creating Ansible Service Broker...           ==
============================================================
[2019-07-23T11:06:35.577Z] [NOTICE] - Initializing clients...
[2019-07-23T11:06:35.579Z] [DEBUG] - Connecting to Cluster
time="2019-07-23T11:06:35Z" level=info msg="OpenShift version: v3.10.153"
[2019-07-23T11:06:35.599Z] [DEBUG] - Connecting Dao
time="2019-07-23T11:06:35Z" level=info msg="Kubernetes version: v1.10.0+b81c8f8"
[2019-07-23T11:06:35.599Z] [DEBUG] - Connecting Registry
time="2019-07-23T11:06:35Z" level=info msg="== REGISTRY CX == "
time="2019-07-23T11:06:35Z" level=info msg="Name: rh"
time="2019-07-23T11:06:35Z" level=info msg="Type: rhcc"
time="2019-07-23T11:06:35Z" level=info msg="Url: https://registry.access.stage.redhat.com"
[2019-07-23T11:06:35.599Z] [DEBUG] - Initializing WorkEngine
[2019-07-23T11:06:35.599Z] [DEBUG] - Creating AnsibleBroker
============================================================
==           Starting Ansible Service Broker...           ==
============================================================
[2019-07-23T11:06:35.599Z] [INFO] - Initiating Recovery Process
[2019-07-23T11:06:35.605Z] [INFO] - Recovery complete
[2019-07-23T11:06:35.605Z] [NOTICE] - recover called
[2019-07-23T11:06:35.605Z] [INFO] - Broker configured to bootstrap on startup
[2019-07-23T11:06:35.605Z] [INFO] - Attempting bootstrap...
[2019-07-23T11:06:35.605Z] [INFO] - AnsibleBroker::Bootstrap
[2019-07-23T11:06:35.605Z] [DEBUG] - Dao::BatchGetSpecs
[2019-07-23T11:06:35.775Z] [WARNING] - registry: 0x15848a0 was unable to complete bootstrap - Get https://registry.access.stage.redhat.com/v1/search?q="*-apb": x509: certificate signed by unknown authority
[2019-07-23T11:06:35.775Z] [ERROR] - Failed to bootstrap on startup!
[2019-07-23T11:06:35.775Z] [ERROR] - all registries failed on bootstrap
time="2019-07-23T11:06:35Z" level=error msg="unable to retrieve image names for registry rh - Get https://registry.access.stage.redhat.com/v1/search?q=\"*-apb\": x509: certificate signed by unknown authority"

Comment 1 Jian Zhang 2019-07-23 11:53:40 UTC

*** This bug has been marked as a duplicate of bug 1696113 ***


Note You need to log in before you can comment on or make changes to this bug.