Bug 1732447 - Sat 6.5.1: RHEL8 ks from boot disk: "dracut: FATAL: For argument ip=x.x.x.x Sorry, unknown value"
Summary: Sat 6.5.1: RHEL8 ks from boot disk: "dracut: FATAL: For argument ip=x.x.x.x S...
Keywords:
Status: CLOSED DUPLICATE of bug 1726830
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Provisioning
Version: 6.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Roman Plevka
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-23 12:29 UTC by Daniel
Modified: 2019-07-23 13:04 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-23 13:04:06 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Daniel 2019-07-23 12:29:45 UTC
Description of problem: 

When trying to provision a RHEL8 host after generating a boot disk. iPXE loads unattended, kernel boots, dracut chokes on "ip=x.x.x.x" from kernel boot line.

Version-Release number of selected component (if applicable): Satellite 6.5.0, 6.5.1, RHEL8.0 kickstart repo (x86_64). Working on RHEL7.6 with same Satellite versions.


How reproducible: 

Simply generate a boot disk from a host entry and attempt to boot.


Steps to Reproduce:
1. Create host entry as normal.
2. Click "Boot disk", download, attach to VM and boot.
3. dracut will halt the process due to perceived syntactical errors.

Actual results:

dracut: FATAL: For argument 'ip=x.x.x.x'\nSorry, unknown value 'x.x.x.x'

Expected results:

VM should be provisioned as normal.


Additional info: 

boot line as follows:

kernel http://sat-test.hiddenfoo.de/pulp/repos/FOO/Library/content/dist/rhel8/8/x86_64/baseos/kickstart//images/pxeboot/vmlinuz initrd=initrd.img ks=http://sat-test.hiddenfoo.de/unattended/provision?token=d73c5ea8-da85-4ca6-855b-79474bf6372e inst.stage2=http://sat-test.hiddenfoo.de/pulp/repos/FOO/Library/content/dist/rhel8/8/x86_64/baseos/kickstart/  &static=yes ksdevice=00:50:56:8e:eb:9a network kssendmac ks.sendmac inst.ks.sendmac ip=${netX/ip} netmask=${netX/netmask} gateway=${netX/gateway} dns=${dns}
initrd http://sat-test.hiddenfoo.de/pulp/repos/FOO/Library/content/dist/rhel8/8/x86_64/baseos/kickstart//images/pxeboot/initrd.img

Comment 3 Evgeni Golov 2019-07-23 13:04:06 UTC

*** This bug has been marked as a duplicate of bug 1726830 ***


Note You need to log in before you can comment on or make changes to this bug.