Bug 173251 - buildinstall when CanonArch == ppc
buildinstall when CanonArch == ppc
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-15 12:36 EST by Mike McLean
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-14 16:45:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike McLean 2005-11-15 12:36:16 EST
If you try to run buildinstall for our ppc product in a buildroot with
'ppc-redhat-linux' in /etc/rpm/platform, the operation fails because
buildinstall doesn't think that either of the kernels are valid (ppc64,
ppc64iseries).

It seems entirely reasonable to have these contents in /etc/rpm/platform, yet it
breaks buildinstall. Perhaps buildinstall (or possibly rhpl) can be taught to be
more accomodating?

>>> hl = hdrlist.HeaderListFromFile(path_to_ppc_hdlist)
>>> hl['kernel']
Traceback (most recent call last):
  File "<stdin>", line 1, in ?
  File
"/mnt/redhat/devel/mikem/mikem-nahant-re1115.1/ppc/buildinstall.dir/usr/lib/anaconda/hdrlist.py",
line 422, in __getitem__
    raise KeyError, "No such package %s" %(item,)
KeyError: 'No such package kernel'
Comment 1 Jeremy Katz 2005-11-15 13:02:55 EST
/etc/rpm/platform in buildroots causes other problems -- you won't be able to do
builds with --target properly either.
Comment 2 Dennis Gregorovic 2006-12-19 17:27:18 EST
Is this still an issue?
Comment 3 Mike McLean 2006-12-20 11:58:26 EST
I haven't hit this in a while.
Comment 4 Chris Lumens 2007-03-14 16:45:07 EDT
Closing on the basis of comment #3.

Note You need to log in before you can comment on or make changes to this bug.