Bug 1732577 - Unable to restart marketplace when default opsrcs are marked for deletion
Summary: Unable to restart marketplace when default opsrcs are marked for deletion
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.2.0
Assignee: Kevin Rizza
QA Contact: Fan Jia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-23 19:14 UTC by Kevin Rizza
Modified: 2019-10-16 06:31 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 06:30:48 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github operator-framework operator-marketplace pull 232 None None None 2019-07-25 13:36:19 UTC
Red Hat Product Errata RHBA-2019:2922 None None None 2019-10-16 06:31:00 UTC

Description Kevin Rizza 2019-07-23 19:14:16 UTC
Description of problem:

Edge case with the new marketplace default operator source implementation.

If, when an operator source is marked for deletion but the operator has not yet removed the deletion finalizer, the operator restarts it will exit with an error.


Version-Release number of selected component (if applicable):

4.2.0


How reproducible:

Always.


Steps to Reproduce:
1. oc delete opsrc community-operators
2. stop the marketplace-operator pod before the deletion reconciler removes the finalizer from the community-operators opsrc
3. restart the marketplace operator

Actual results:
The operator fails to start


Expected results:
The operator should restart, delete the community-operators opsrc and immediately recreate it.

Comment 2 Fan Jia 2019-09-05 01:47:41 UTC
test env:
cv:4.2.0-0.nightly-2019-09-03-062724

test result:
1. unmanaged the marketplace-operator by cvo, 
2. edit the replicas of deployment marketplace-operator to "0", 
3. delete default opsrc "redhat-operators", 
4. edit the replicas of deployment marketplace-operator to "1"

no error message in the logs of marketplace-operator container and the opsrc "redhat-operators" is deleted first and recreated immediately.

Comment 3 errata-xmlrpc 2019-10-16 06:30:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.