Bug 1732579 - CatalogSources should be permissive to errors in manifests
Summary: CatalogSources should be permissive to errors in manifests
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.2.0
Assignee: Evan Cordell
QA Contact: Fan Jia
URL:
Whiteboard:
Depends On:
Blocks: 1732580
TreeView+ depends on / blocked
 
Reported: 2019-07-23 19:17 UTC by Evan Cordell
Modified: 2019-10-16 06:31 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 06:30:48 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github operator-framework operator-registry pull 69 'None' 'closed' 'Bug 1732579: Best-effort loading' 2019-11-15 06:44:39 UTC
Red Hat Product Errata RHBA-2019:2922 None None None 2019-10-16 06:31:00 UTC

Description Evan Cordell 2019-07-23 19:17:17 UTC
Description of problem:

Operator-Registry is a component of OLM that serves operator metadata for a cluster. These servers get built at runtime by the marketplace-operator, which reads from a remote appregistry store and parses them for local use. Any number of issues can arise with the parsing of these manifests which causes the pod serving this data to fail with an error message.

Instead of failing, operator-registry should be permissive in the parsing of manifests, so that an entire catalog isn't out of commission if there are errors in the source data.


How reproducible:

Always


Steps to Reproduce:

(as an example)
1. Push manifests to an appregistry repo (like community-operators) that has a ClusterServiceVersion with a "replaces" field set to "thisWillFail"
2. Create an OperatorSource pointing to this appregistry repo
3. Note the failing pod in the cluster.

Actual results:

The CatalogSource pod never becomes healthy.


Expected results:

The CatalogSource loads, with bad manifests removed.

Comment 3 errata-xmlrpc 2019-10-16 06:30:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.