Bug 1732593 - clang++ -g does not emit debugging info for some types
Summary: clang++ -g does not emit debugging info for some types
Keywords:
Status: CLOSED DUPLICATE of bug 1740927
Alias: None
Product: Fedora
Classification: Fedora
Component: clang
Version: 30
Hardware: x86_64
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Tom Stellard
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-23 20:06 UTC by baconeater789
Modified: 2019-12-18 18:29 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-12-18 18:29:28 UTC


Attachments (Terms of Use)

Description baconeater789 2019-07-23 20:06:34 UTC
Description of problem:

"clang++ -g main.cc" does not emit debugging information for certain types such as std::string.

Version-Release number of selected component (if applicable):

clang-8.0.0-1.fc30.x86_64

How reproducible:

Always

Steps to Reproduce:
1. std::string my_string{"foo"}
2. Set a breakpoint in lldb past the string declaration
3. In LLDB: "frame var --raw my_string"

Actual results:

(std::string) my_string = {}

Expected results:

(std::string) my_string = {
  _M_dataplus = {
    _M_p = 0x00007fffffffd618
  }
  _M_string_length = 3
   = {
    _M_local_buf = {
      [0] = 'f'
      [1] = 'o'
      [2] = 'o'
      [3] = '\0'
      [4] = '\0'
      [5] = '\0'
      [6] = '\0'
      [7] = '\0'
      [8] = '\x10'
      [9] = '\xd7'
      [10] = '\xff'
      [11] = '\xff'
      [12] = '\xff'
      [13] = '\x7f'
      [14] = '\0'
      [15] = '\0'
    }
    _M_allocated_capacity = 7303014
  }
}


Additional info:

Debug information is produced as expected on Ubuntu 19.04 with "clang++ -g main.cc".

Debug information is included if built with "clang++ -g -fno-limit-debug-info main.cc".  I believe "-g" should include debug information though.

Comment 1 Jan Kratochvil 2019-12-18 18:29:28 UTC
It is being worked on - missing DWZ support in LLDB.  It is already tracked by Bug 1740927.

*** This bug has been marked as a duplicate of bug 1740927 ***


Note You need to log in before you can comment on or make changes to this bug.