Bug 17326 - SysRq Boot does not work
Summary: SysRq Boot does not work
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-09-07 14:12 UTC by David Balažic
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-07 17:31:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Balažic 2000-09-07 14:12:17 UTC
SysRq + B ( Boot , should reboot the machine )
does not work for me. The other SysRq key all work.

Second, SysRq + L ( killalL , kill all processes )
freezes the computer. VT switching doesn't work anymore,
the Caps Lock LED doesn't change on the key press.
Weirdly the power-off button works.
It is a soft-power-off button and if the correct
code is not running, one must hold it for 4 seconds
to power off.

Comment 1 David Balažic 2001-01-22 16:17:58 UTC
Same thing with Florence beta2 on an updated machine.
( it is still the same keyboard )

Comment 2 Arjan van de Ven 2001-01-23 09:32:15 UTC
From the Documentation/sysrq.txt file:

'i'     - Send a SIGKILL to all processes, except for init.

'l'     - Send a SIGKILL to all processes, INCLUDING init. (Your system
          will be non-functional after this.)

so the "L stops functioning" is not a bug but intended behavior.
The "b" is still a bug

Comment 3 David Balažic 2001-02-07 17:31:44 UTC
Still doesn't work.

I patched to kernel to perform a reboot on SysRq+H instead
of SysRq+B and it works, pressing SysRq+H will reboot the system.

Seems like the keyboard can't handle certain key combinations.
For the record :

Keyboard is PS/2 with slovenian layout , Cherry G83.
Details printed on the bottom side :

model : RS 6000 M
typ : 35
part. no. : G83-6105LRNSL/ 01
serial.no. : G 0019260 5K44 3 ||



Note You need to log in before you can comment on or make changes to this bug.