Bug 1732656 - Unable to generate Ansible Remediation Playbook for Compliance
Summary: Unable to generate Ansible Remediation Playbook for Compliance
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Cloud Software Services (cloud.redhat.com)
Classification: Red Hat
Component: Compliance
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: ---
Assignee: Daniel Lobato Garcia
QA Contact: Victor M.
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-24 04:41 UTC by Nikhil Gupta
Modified: 2020-01-28 12:59 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-28 12:59:48 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Nikhil Gupta 2019-07-24 04:41:49 UTC
Description of problem:
In Cloud Management Services, Compliance tab's -> "Remediate with Ansible" button does not work. Not able to generate playbook.

How reproducible:
Always

Steps to Reproduce:
1) CMS > Compliance
2) System > Click on the system profile
3) In FIlters -> Select "Hide passed rules"
4) Select rules where Ansible Playbook is available
5) "Remediate with Ansible" turns blue and becomes active
6) Click on the "Remediate with Ansible"

Actual results:
The "Remediate with Ansible" button does not give any response and playbook is not generated.

Expected results:
The playbook should be generated.

Additional info:
This was fixed in Bug-1708205, however, it seems like the issue is back.

Comment 1 Daniel Lobato Garcia 2019-07-24 12:47:07 UTC
https://github.com/RedHatInsights/frontend-components/pull/90 fixes it, the fix is already published in internal CI and prod-beta


Note You need to log in before you can comment on or make changes to this bug.