Bug 1732698 - The es node count in clusterlogging instance status is not correct when es nodeCount > 3.
Summary: The es node count in clusterlogging instance status is not correct when es no...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.5.0
Assignee: Periklis Tsirakidis
QA Contact: Anping Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-24 07:28 UTC by Qiaoling Tang
Modified: 2020-07-13 17:11 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Reading the wrong CR status fields to node count from elasticsearch CR. Consequence: Incorrect node count propagated from elasticsearch status to cluster logging CR status Fix: Use the correct field. Result: Correct node count propagated from elasticsearch CR to cluster logging CR status.
Clone Of:
Environment:
Last Closed: 2020-07-13 17:11:03 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-logging-operator pull 498 0 None closed Bug 1732698: Fix fetching node count from elastichsearch status 2020-09-11 06:20:53 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:11:19 UTC

Description Qiaoling Tang 2019-07-24 07:28:15 UTC
Description of problem:
Deploy logging, set ES nodeCount > 3, then check the status in clusterlogging instance, the nodeCount is always 3

    logStore:
      elasticsearchStatus:
      - ShardAllocationEnabled: all
        cluster:
          activePrimaryShards: 6
          activeShards: 30
          initializingShards: 0
          numDataNodes: 5
          numNodes: 5
          pendingTasks: 0
          relocatingShards: 0
          status: green
          unassignedShards: 0
        clusterName: elasticsearch
        nodeConditions:
          elasticsearch-cd-qw0rlndh-1: []
          elasticsearch-cd-qw0rlndh-2: []
          elasticsearch-cdm-93f80lxs-1: []
          elasticsearch-cdm-93f80lxs-2: []
          elasticsearch-cdm-93f80lxs-3: []
        nodeCount: 3
        pods:
          client:
            failed: []
            notReady: []
            ready:
            - elasticsearch-cd-qw0rlndh-1-7d4855f9fb-9cgdf
            - elasticsearch-cd-qw0rlndh-2-6458b5b44-677rv
            - elasticsearch-cdm-93f80lxs-1-7dcc88c567-5hctf
            - elasticsearch-cdm-93f80lxs-2-c465cd4db-6wzbq
            - elasticsearch-cdm-93f80lxs-3-5f7f8dd6f8-jm8rn
          data:
            failed: []
            notReady: []
            ready:
            - elasticsearch-cd-qw0rlndh-1-7d4855f9fb-9cgdf
            - elasticsearch-cd-qw0rlndh-2-6458b5b44-677rv
            - elasticsearch-cdm-93f80lxs-1-7dcc88c567-5hctf
            - elasticsearch-cdm-93f80lxs-2-c465cd4db-6wzbq
            - elasticsearch-cdm-93f80lxs-3-5f7f8dd6f8-jm8rn
          master:
            failed: []
            notReady: []
            ready:
            - elasticsearch-cdm-93f80lxs-1-7dcc88c567-5hctf
            - elasticsearch-cdm-93f80lxs-2-c465cd4db-6wzbq
            - elasticsearch-cdm-93f80lxs-3-5f7f8dd6f8-jm8rn


Version-Release number of selected component (if applicable):
ose-cluster-logging-operator-v4.2.0-201907232219


How reproducible:
Always

Steps to Reproduce:
1. deploy logging, set es nodeCount > 3
2. check the status in clusterlogging instance
3.

Actual results:


Expected results:


Additional info:

Comment 4 Anping Li 2020-05-06 13:20:19 UTC
verified in  clusterlogging.v4.5.0
 logStore:
    elasticsearchStatus:
    - cluster:
        activePrimaryShards: 64
        activeShards: 64
        initializingShards: 1
        numDataNodes: 4
        numNodes: 4
        pendingTasks: 0
        relocatingShards: 0
        status: yellow
        unassignedShards: 0
      clusterName: elasticsearch
      nodeConditions:
        elasticsearch-cd-27k3wtz7-1: []
        elasticsearch-cdm-ya1nz4gf-1: []
        elasticsearch-cdm-ya1nz4gf-2: []
        elasticsearch-cdm-ya1nz4gf-3: []
      nodeCount: 4

Comment 6 errata-xmlrpc 2020-07-13 17:11:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.